Bug report #17719

Dragging and dropping MS SQL table in browser window causes overwriting of existing table

Added by Matthew Baker almost 3 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:2.18.14 Regression?:No
Operating System:WINDOWS 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:25615

Description

Today I experienced a very strange behaviour from the browser window working with tables in my MS SQL connection.

I inadvertently dragged and dropped a layer into the same connection/schema. The table was dropped and re-created with the same name, but all the data lost, and instead of the OBJECTID field I had created in the original SQL, it had created a QGISID (or similar) field.

In addition to this issue, I have great concerns with abilities within the browser window in regards to dragging and dropping layers and how new tables are created. This applies to PostGIS tables as well.

I'm not sure if this is a bug, or a feature request, but when working with database tables such as MS SQL, PostGIS, etc., why does the browser window have these abilities when the DB manager GUI such as MSSQL or PGAdmin, or other tools such as DataGrip, should be where these actions take place?


Related issues

Duplicates QGIS Application - Bug report #16805: Corrupting SQL Server tables when using drag and drop in ... Closed 2017-07-07

History

#1 Updated by Nathan Woodrow almost 3 years ago

  • Duplicates Bug report #16805: Corrupting SQL Server tables when using drag and drop in QGIS browser added

#2 Updated by Nathan Woodrow almost 3 years ago

Thanks. Yeah, this is not ideal at all. If someone else doesn't fix this I will fix it before the next patch release.

#3 Updated by Matthew Baker almost 3 years ago

Oh thanks, Nathan! Happy to test anything MSSQL as we are heavy users with QGIS. Thanks again!

Nathan Woodrow wrote:

Thanks. Yeah, this is not ideal at all. If someone else doesn't fix this I will fix it before the next patch release.

#4 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#5 Updated by Nyall Dawson about 2 years ago

  • Category changed from Browser to Data Provider/MSSQL

#6 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicate of #16805

#7 Updated by Matthew Baker about 2 years ago

Do you think the ability to drag and drop tables in the browser window will be removed entirely in lieu of using a DBA gui (DBeaver, Datagrip, etc.) instead?

Nyall Dawson wrote:

Duplicate of #16805

#8 Updated by Nyall Dawson about 2 years ago

Do you think the ability to drag and drop tables in the browser window will be removed entirely in lieu of using a DBA gui (DBeaver, Datagrip, etc.) instead?

No - that's a feature, not a bug !

Also available in: Atom PDF