Bug report #17691

Applying any file-based qml style to a postgres table results in applying its default style

Added by Harrissou Santanna about 2 years ago. Updated 11 months ago.

Status:Open
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:3.0.0 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:25588

Description

Let's take a PG table with a default style (seems there's no issue if it has no default style filled) and change some of its symbology in the project.
Also take a layer style you saved in qml (different from the default style)
Try to apply the qml style to the PG table.
Nothing will change but the PG table reverting to its default style.

Tested on 2.18.15-dev osgeo4w (not yet in the list). FYI, tried it also on 2.18.0 (macOS) and it works there.

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Priority changed from Normal to High

#2 Updated by Harrissou Santanna almost 2 years ago

  • Affected QGIS version changed from 2.18.14 to 3.0.0

#3 Updated by Nyall Dawson almost 2 years ago

I can reproduce this in 2.18 also.

#4 Updated by Paolo Cavallini about 1 year ago

Could you please check again on current release?
Thanks.

#5 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Paolo Cavallini wrote:

Could you please check again on current release?
Thanks.

Please change status to "feedback" when needed.

#6 Updated by Giovanni Manghi 11 months ago

  • Status changed from Feedback to Closed
  • Resolution set to end of life

#7 Updated by Giovanni Manghi 11 months ago

  • Resolution deleted (end of life)
  • Status changed from Closed to Open

Also available in: Atom PDF