Bug report #17630

Annotations not showing in Composer on OSX

Added by Eron Lloyd almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.18.14 Regression?:Yes
Operating System:OSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25527

Description

I am reporting a confirmed bug with creating Composer maps that have canvas annotations1. Using OS X the annotations are displayed on the map but do not show up in the Composer nor any rendered files from Composer. This is with the check box to display canvas items selected. The same project file, however, loaded in a Windows desktop, will load annotations in Composer just fine.

The two environments I tested in was OS X 10.13.1 running QGIS 2.18.14, and Windows 7 Pro running QGIS 2.18.14.

[1] https://gis.stackexchange.com/questions/255906/text-annotation-not-appearing-in-print-composer/262304

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Open to Feedback

Could you give a try on QGIS master (where the composer was overhauled)?

#2 Updated by Eron Lloyd almost 3 years ago

Is there a specific OS X build that is available to try? It looks like the Dakota Cartography nightly builds haven't been maintained... I'd love to test the 3.0 RC, but don't see a package for that, either.

#3 Updated by Giovanni Manghi over 2 years ago

QGIS 3 is "out", wait for the packages, test and leave feedback, thanks!

#4 Updated by Eron Lloyd over 2 years ago

Eron Lloyd wrote:

Is there a specific OS X build that is available to try? It looks like the Dakota Cartography nightly builds haven't been maintained... I'd love to test the 3.0 RC, but don't see a package for that, either.

Fixed! Thanks for the follow up, Giovanni :-)

#5 Updated by Nyall Dawson over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF