Bug report #17525

subform in automatic generated relation referende widget is not visible in 2.99 QGIS-Codeversion b058df7d1d

Added by Gerhard Spieles almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Forms
Affected QGIS version:3.0.0 Regression?:No
Operating System:win 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:25422

Description

In automatic generated relation reference widget, the subform is no more visible in 2.99 QGIS-Codeversion b058df7d1d.
Screenshots with form in 2.18.14 (correct form) and 2.99 are attached

automaticrelationreferencewidget2.18.14.jpg (66.7 KB) Gerhard Spieles, 2017-11-22 09:36 PM

automaticrrelatrionreferencewidget2.99.220.jpg (38.8 KB) Gerhard Spieles, 2017-11-22 09:37 PM

subform not visible 2.99 rel. 249_9fb386ac60.jpg (132 KB) Gerhard Spieles, 2017-12-27 09:49 PM

subform visible 2.18.15.jpg (142 KB) Gerhard Spieles, 2017-12-27 09:58 PM

test_parentchild.zip (434 KB) Gerhard Spieles, 2017-12-27 09:58 PM


Related issues

Related to QGIS Application - Bug report #17854: View form with relations does not work Closed 2018-01-15

Associated revisions

Revision 84ec10ee
Added by Matthias Kuhn over 2 years ago

Fix relation editor widget in autogenerated forms

Fix #17525

Revision 72bd89ea
Added by Matthias Kuhn over 2 years ago

Fix relation editor widget in autogenerated forms

Fix #17525

History

#1 Updated by Andreas Neumann almost 3 years ago

Hi Gerhard,

I noticed that in the 2.99 screenshot there is a small triangle indicating that some closed section of the form is available which could be unfolded.

If you click on that triangle - is the subform of the relation reference widget visible then?

#2 Updated by Gerhard Spieles almost 3 years ago

Hallo Andreas,

i had seen and tested this.
When you click and the triangle turned down, it seems that the rounding area changed a little bit, but the subform seems to be minimized and is not visible anymore.

#3 Updated by Pedro Venâncio almost 3 years ago

Hi Gerhard,

I can not confirm this one in 2.99.0, code revision b59bd94e87.

Opening a QGIS 2.18.x project with subforms, they show up well on 2.99.

Can you share the project and some sample data to test?

Best regards,
Pedro

#4 Updated by Gerhard Spieles almost 3 years ago

Testprojects created with
- QGIS 2.99 rel. 249_Code-Version 9fb386ac60is, installed via OSGeo4W,
- QGIS 2.18.15
are attached.

Also jpgs.

#5 Updated by Pedro Venâncio over 2 years ago

Hi Gerhard,

I confirm the problem here, with the "Autogenerate" attribute editor layout.

If you go to parent layer properties -> Attributes form -> change to "Drag and drop designer" attribute editor layout -> add the field from the relation (child_xxx) and everything works ok.

So this must be a problem with the Autogenerate layout in master. Someone with editing permissions should update the subject and the priority of this ticket.

Thanks Gerhard!

#6 Updated by Jürgen Fischer over 2 years ago

#7 Updated by Gerhard Spieles over 2 years ago

Issue is still present in 3.1.0-3 (see Mail Paolo Cavallini, QGIS tickets)

#8 Updated by Nyall Dawson over 2 years ago

  • Regression? changed from No to Yes

#9 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from master to 3.0.0
  • Regression? changed from Yes to No

#10 Updated by nagi hekmati over 2 years ago

in qgis 3 :
i have this problem too
my layer and table are stored in postgis
this feature had worked well in prev version
thanks for soon correction

#11 Updated by Anonymous over 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF