Bug report #17511

adding two instances of the same gpkg layer and editing on one of them crashes qgis

Added by Alessandro Pasotti almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:25408

Description

See #17507 for the sample project and data

steps to reproduce
- load the sample project
- by using the ogr browser, load the gpkg layer (second instance)
- start editing the second instance
- add some features
- end editing (sometimes it crashes here!)
- right click on the first instance (sometimes it crashes here!)


Related issues

Related to QGIS Application - Bug report #17507: Unable to edit filtered GeoPackage layer Closed 2017-11-21

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Priority changed from Normal to High

#3 Updated by Alessandro Pasotti almost 3 years ago

#4 Updated by Jürgen Fischer almost 3 years ago

  • Description updated (diff)

#5 Updated by Even Rouault over 2 years ago

  • Status changed from Open to Feedback

@Alessandro I can't reproduce any crash with master. Unfortunately the http://dpaste.com/2MM3ZC7 has expired since you create it. Do you still have it ?
If you can't reproduce any more, we'd better close this one

#6 Updated by Alessandro Pasotti over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

I cannot reproduce it anymore.

Also available in: Atom PDF