Bug report #17285

QGIS3: reshape doesn't listen to "avoid intersection"

Added by Tobias Wendorff 11 months ago. Updated 6 months ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No

Description

I don't know if it's even planned, but you could expect that reshaping of a polygon follows the rules of "snapping and digitizing options". In advanced settings, i've chosen "avoid intersection". It works for new created polygons, but not for reshaping.

History

#1 Updated by Giovanni Manghi 11 months ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes

This works as expected on 2.18 so it's a regression.

#2 Updated by Nyall Dawson 7 months ago

  • Status changed from Open to Feedback

I can't reproduce. I've tested with 2.18 and 3.0 and the behavior is the same.

Note that reshaping with "avoid intersections" does NOT avoid intersections within the same layer, and it did not in 2.18 either.

Is this still an issue with current nightlies?

#3 Updated by Andreas Wicht 7 months ago

Note that reshaping with "avoid intersections" does NOT avoid intersections within the same layer, and it did not in 2.18 either.

Is that really the case? With my settings (2.18.16) I can't produce overlapping areas with the Reshape tool within the same layer except for this case #16985.

#4 Updated by Tobias Wendorff 6 months ago

Can be closed, all got fixed.

#5 Updated by Nyall Dawson 6 months ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF