Feature request #17219

Better description of bands

Added by Paolo Cavallini about 3 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No Copied to github as #:25118

Description

Some multiband fornmat (I have checked especialli GRIB) have a description in the metadata for the meaning of each band (e.g. wind speed 10 m above ground). In the layer properties > Style, only the band numbers are listed (band 1 etc.).
This makes styling very difficult. It would seem reasonable to add the metadata to the band number, e.g.:
Band 1 (wind speed 10 m above ground)

Screenshot_20180116_144439.png (1.2 MB) Giovanni Manghi, 2018-01-16 03:46 PM


Related issues

Related to QGIS Application - Bug report #19586: Problem reading grib file Closed 2018-08-10

History

#1 Updated by Nyall Dawson about 3 years ago

  • Status changed from Open to Feedback

Can you share one of these files?

#2 Updated by Paolo Cavallini about 3 years ago

http://www.faunalia.eu/~paolo/grib.zip
Thanks.
BTW: I do not know whether this is a general issue, but the projection for this particular file (EPSG:4326) is not correctly interpreted.

#3 Updated by Paolo Cavallini almost 3 years ago

Misinterpretation of EPSG code confirmed with other GRIBs from other sources.

#4 Updated by Giovanni Manghi almost 3 years ago

Paolo Cavallini wrote:

Misinterpretation of EPSG code confirmed with other GRIBs from other sources.

here on 2.18.* and gdal 2.2.2:

both gdal (and qgis) read a custom CRS (+proj=longlat +a=6367470 +b=6367470 +no_defs) but this definitely seems to reproject to the right place, see attached image.

#5 Updated by Paolo Cavallini almost 3 years ago

Confirmed, thanks for checking. As mentioned in mailing list, GRIBS dowloaded and correctly visualized in ZyGrib are not projected correctly, see http://www.faunalia.eu/~paolo/grib2.bz2
This is outside the scope of the current ticket however.

#6 Updated by Giovanni Manghi almost 3 years ago

Paolo Cavallini wrote:

Confirmed, thanks for checking. As mentioned in mailing list, GRIBS dowloaded and correctly visualized in ZyGrib are not projected correctly, see http://www.faunalia.eu/~paolo/grib2.bz2
This is outside the scope of the current ticket however.

gdalinfo reports messages like

Band 1206 Block=109x1 Type=Float64, ColorInterp=Undefined
Description = 0[-] SFC (Ground or water surface)
Un-handled possible ensemble section center 58 subcenter 0
Warning 1: Band 1206 of GRIB dataset is 130x99, while the first band and dataset is 109x89. Georeferencing of band 1206 may be incorrect, and data access may be incomplete.
NoData Value=9999
Metadata:
GRIB_COMMENT=undefined [-]
GRIB_ELEMENT=var155
GRIB_FORECAST_SECONDS=345600 sec
GRIB_REF_TIME= 1515456000 sec UTC
GRIB_SHORT_NAME=0-SFC
GRIB_UNIT=[-]
GRIB_VALID_TIME= 1515801600 sec UTC

so I would say it is GDAL or zygrib problem.

#7 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to up/downstream

#8 Updated by Paolo Cavallini almost 3 years ago

  • Resolution deleted (up/downstream)

We are mixing up things here, my fault.
1. the projection issue: unclear whether this is due to QGIS misinterpreting EPSG:4326 or Zygrib/GDAL providing invalid projection; I will do more research
2. wrong extent: brilliantly clarified by Giovanni, thanks
3. description of bands: remains valid, it' a QGIS GUI issue, possibly not too difficult.
Thanks all for feedback.

#10 Updated by Paolo Cavallini almost 3 years ago

Projection issue seems due to Zygrib, in any case not to QGIS:

Driver: GRIB/GRIdded Binary (.grb)
Files: ECMWF0100_2017030100_000.grb
Size is 181, 161
Coordinate System is:
GEOGCS["Coordinate System imported from GRIB file",
DATUM["unknown",
SPHEROID["Sphere",6367470,0]],
PRIMEM["Greenwich",0],
UNIT["degree",0.0174532925199433]]
Origin = (1.950000000000000,50.049999999999997)
Pixel Size = (0.100000000000000,-0.100000000000000)
Corner Coordinates:
Upper Left ( 1.9500000, 50.0500000) ( 1d57' 0.00"E, 50d 3' 0.00"N)
Lower Left ( 1.9500000, 33.9500000) ( 1d57' 0.00"E, 33d57' 0.00"N)
Upper Right ( 20.0500000, 50.0500000) ( 20d 3' 0.00"E, 50d 3' 0.00"N)
Lower Right ( 20.0500000, 33.9500000) ( 20d 3' 0.00"E, 33d57' 0.00"N)
Center ( 11.0000000, 42.0000000) ( 11d 0' 0.00"E, 42d 0' 0.00"N)

#11 Updated by Paolo Cavallini almost 3 years ago

So we can go back to the original issue: showing in the name of bands also their description, as reported by GDAL, to make it easier for users to interpret and symbolize data.

#12 Updated by Paolo Cavallini over 2 years ago

  • Status changed from Feedback to Open

#13 Updated by Saber Razmjooei about 2 years ago

#15 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Open to Feedback

#16 Updated by Paolo Cavallini about 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Confirmed, thanks.

Also available in: Atom PDF