Bug report #17137

Parsing some Certificate Authorities causes crash

Added by Larry Shaffer over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Authentication system
Affected QGIS version:master Regression?:Yes
Operating System:macOS 10.11.6 Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:25036

Description

When parsing some CAs, e.g. when double-clicking for opening Cert Info dialog, immediately causes QGIS to crash with report (see attached).

Appears to be either a problem with too-new certs to be read by QCA, or the QCA code under Qt5 has a bug that did not present under Qt4.

qgis-issue_17137.txt Magnifier (23.5 KB) Larry Shaffer, 2017-09-14 01:04 AM

History

#2 Updated by Larry Shaffer over 2 years ago

This happens when the cert's public key algorithm is based upon elliptic curve.

#3 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#4 Updated by Denis Rouzaud over 1 year ago

  • Subject changed from Parsing some Certificate Authorities on macOS causes crash to Parsing some Certificate Authorities causes crash

#5 Updated by Jürgen Fischer over 1 year ago

  • Assignee deleted (Larry Shaffer)

#6 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#7 Updated by Nyall Dawson over 1 year ago

  • Status changed from Feedback to Closed

Closed due to lack of feedback

#8 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to no timely feedback

Also available in: Atom PDF