Bug report #17061

Using Data Defined Assistant on symbol size property set the symbol invisible in the layer properties dialog

Added by Harrissou Santanna almost 3 years ago. Updated over 1 year ago.

Status:Open
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:3.4.3 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24960

Description

Take a point layer --> Layer Properties --> Single symbol
Use the Assistant option of the data defined button near the size property to draw a proportional symbol
Back to the single symbol dialog, you'll notice that there is no symbol beside the "Marker" text at the top of the dialog.

Note that you do not have this issue if you just pick a field from the data-defined button nor if you copy paste the assistant expression in the expression builder (though i'm not sure the behavior of the legend is then the right one).

Using the "old-way" DD assistant in 2.18 does work well.

DDproportional.PNG - No symbol for the marker (17.9 KB) Harrissou Santanna, 2017-08-24 05:04 PM

DDproportionalv2.PNG - symbol on the right but not in tree view nor layers panel (60.7 KB) Harrissou Santanna, 2018-02-27 05:57 PM

unavailablePreview.png - The symbol is shown only next to the Marker level (60.5 KB) Harrissou Santanna, 2019-01-16 04:29 PM

Associated revisions

Revision 23dc1c8f
Added by Nyall Dawson over 2 years ago

Use first feature in layer to generate symbol preview icon in widget

Uses the first feature found in a layer in order to create a better
preview for the symbol in the symbol selector dialog. This allows
data defined settings to be evaluated correctly (at least, for the
first feature) and avoids missing previews due to missing
attribute values when data defined settings are present.

Fixes #17061

History

#1 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to In Progress
  • Pull Request or Patch supplied changed from No to Yes

#2 Updated by Nyall Dawson over 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

#4 Updated by Harrissou Santanna over 2 years ago

  • Resolution deleted (fixed/implemented)
  • Status changed from Closed to Reopened
  • File DDproportionalv2.PNG added

Using e1a344f725, this is still true. actually, the symbol is displayed in the right side of the dialog but nothing in the tree view nor the layers panel (see DDproportionalv2 screenshot)

#5 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from master to 3.1(master)

#6 Updated by Paolo Cavallini over 1 year ago

Could you please check again on current release?
Thanks.

#7 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Reopened to Feedback

Paolo Cavallini wrote:

Could you please check again on current release?
Thanks.

Please change status to "feedback" when needed.

#8 Updated by Harrissou Santanna over 1 year ago

  • Subject changed from Using Data Defined Assistant on symbol size property set the symbol invisible to Using Data Defined Assistant on symbol size property set the symbol invisible in the layer properties dialog
  • File unavailablePreview.png added
  • Status changed from Feedback to Open
  • Affected QGIS version changed from 3.1(master) to 3.4.3

It's kind of still there: the symbol is now shown next to the topmost "marker" text but nothing is shown at the "Simple marker" level in the tree, nor as a preview on the right. See the unavailablePreview.png attached file.

#9 Updated by Harrissou Santanna over 1 year ago

Of course this does not happen if you use a field from the DD widget entry or copy-paste the expression used by the assistant. It's when the assistant is checked that the issue arises afaict.

Also available in: Atom PDF