Bug report #16981

Load vector layer in Processing: wrong filter (on GNOME)

Added by Paolo Cavallini almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/GUI
Affected QGIS version:master Regression?:Yes
Operating System:Debian/Gnome Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24880

Description

Loading a layer from the filesystem in a Processing module does not filter layer types; this is confusing, only vector extensions should be shown.

file_open.png (42 KB) Paolo Cavallini, 2017-08-07 12:14 PM

History

#1 Updated by Paolo Cavallini almost 3 years ago

This on Debian Sid/Gnome3

#2 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Open to Feedback

what does it show if you click on that "all files" button?

#3 Updated by Paolo Cavallini almost 3 years ago

Just All files and an empty line.

#4 Updated by Giovanni Manghi almost 3 years ago

  • Regression? changed from No to Yes
  • Subject changed from Load vector layer in Processing: wrong filter to Load vector layer in Processing: wrong filter (on GNOME)
  • Priority changed from Normal to High
  • Operating System set to Debian/Gnome

#5 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Feedback to Open

On Windows it works as expected.

#6 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

I can't reproduce on gnome - is this still an issue on master?

#7 Updated by Paolo Cavallini over 2 years ago

Still true as per 5522f10eb6
I can test a newer master in a few days if necessary.

#8 Updated by Mathieu Pellerin - nIRV over 2 years ago

I have a feeling there was a lack of clarity on in this report :)

I can reproduce this with algorithms with a map (i.e. vector and raster) layer parameter (for e.g. extract layer extent).

#9 Updated by Paolo Cavallini over 2 years ago

You are right, sorry.
Thanks for checking.

#10 Updated by Mathieu Pellerin - nIRV over 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Paolo, no worries, it's now fixed.

Issues are better served with a bullet point "steps to reproduce" list, try that next time ;-) thanks for reporting this.

#11 Updated by Paolo Cavallini over 2 years ago

Of course, I know. Unfortunately sometime time is really impossible to find, and I feel it is better not to forget an issue - clarifications can be provided also later.
Anyway, thanks for the fix!

Also available in: Atom PDF