Bug report #16911

Spatial query plugin and disjoint operator is wrong

Added by Etienne MORO about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:C++ plugins/Spatial Query
Affected QGIS version:2.18.11 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:24810

Description

The result of a spatial query (using the spatial query plugin) with the operator 'disjoint' is wrong.
For example, using the 2 SHP attached:
COMMUNE disjoint CHEF_LIEU -> the result contains 2 COMMUNE with a CHEF_LIEU inside !
This function work well without this bug in QGis 2.14

COMMUNE-CHEFLIEU.zip (63 KB) Etienne MORO, 2017-07-21 04:14 PM

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Operating System deleted (Windows 7, Windows 10)

Confirmed on Linux too.

#2 Updated by Giovanni Manghi about 3 years ago

  • Affected QGIS version changed from 2.18.10 to 2.18.11

#3 Updated by Alexander Bruy almost 3 years ago

Spatial Query plugin is not maintained. Use Processing (Select By Location, Extract By Location) instead, these algorithms much more flexible.

#4 Updated by Alexander Bruy almost 3 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Closed as "won't fix" because plugin removed from master and there is working alternative in Processing

Also available in: Atom PDF