Feature request #1688

Assign layer CRS to project (legend context menu)

Added by springmeyer - over 11 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Borys Jurgiel
Category:Projection Support
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:11748

Description

I think this would be a big usability improvement. It should be able to be turned off however (wildintellect), but the default behavior when opening a new project should be that the Map CRS inherits from the CRS from the layer, when possible.

Perhaps I am missing something however - the text in the QGIS Options CRS tabs says: 'when layer is load that has no coordinate reference system (CRS)' do...

I have 'Prompt for CRS Checked' and when I open a shapefile in BC albers (epsg 3005)

PROJCS[[PCS_Albers"GEOGCS["GCS_North_American_1983"DATUM["D_North_American_1983"SPHEROID["GRS_1980"63781370298257222101]]PRIMEM["Greenwich"00]UNIT["Degree"00174532925199433]]PROJECTION["Albers"]PARAMETER["False_Easting"10000000]PARAMETER["False_Northing"00]PARAMETER["Central_Meridian"-1260]PARAMETER["Standard_Parallel_1"500]PARAMETER["Standard_Parallel_2"585]PARAMETER["Latitude_Of_Origin"450]UNIT["Meter]]

...the map still defaults to EPSG 4326, which is not the behavior I would assume based on that description.

Is something wrong with my system or is that description of out sync with intended behavior?

History

#1 Updated by Magnus Homann about 11 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

It means that if there is no information about the CRS for the layer, what to do then?

As long as you don't have projection turned on, the map CRS doesn't matter. When you turn it on, you also specify the "map" CRS.

What you suggst was the behaviour a few years back, but I think the current situation is cleaner and more predictable.

#2 Updated by Borys Jurgiel over 9 years ago

  • Resolution deleted (wontfix)
  • Status changed from Closed to Feedback

What about a "Set Project CRS to this layer" in the Legend? With OTFR enabled, this way we could easily switch between various target CRSes. With OTFR disabled, we could easily synchronize map units. And it would me much more predictable, than automatic setting to the first layer.

By the way: I totally disagree with the "As long as you don't have projection turned on, the map CRS doesn't matter". This way you have broken scale, broken scale line, and limited possibility to assign project crs to newly created layers. Also, it just makes a mess. If you don't want to use projections, than the OTFR switch should be rather replaced with a "Projection support" switch to completely detach the missinformating WGS84 CRS.

#3 Updated by Borys Jurgiel over 9 years ago

  • Status changed from Feedback to Open

#4 Updated by Borys Jurgiel over 9 years ago

fixed in c2190016 (SVN r15425)

#5 Updated by Borys Jurgiel over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF