Bug report #16666

New unified add button: file selector sometimes opens behind the Data Source Manager

Added by shenriod - over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Browser
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:24565

Description

When using the new unified "Add data" button, it seems that the File Selector sometimes opens behind the Data Source Manager, when the user clicks on "Browse"

Screencast here: https://vimeo.com/220330186

History

#1 Updated by Alessandro Pasotti over 2 years ago

I cannot reproduce this on KDE/Linux. Maybe something specific to Ubuntu Unity?

I tested with modal and modeless options.

#2 Updated by Frank Sokolic over 2 years ago

I also get the same thing on Ubuntu 17.10 (Unity desktop) but it also affects other things, not only the Data Source Manager.

If I right click on a vector layer in the Layers Panel and select Save As... and then Browse the File Selector opens in the background.

It seems like this bug is due to something else, not the Data Source Manager.

#3 Updated by Alessandro Pasotti almost 2 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

Also available in: Atom PDF