Bug report #1653

Segmentation Fault in FC10

Added by lookingforoil - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Fedora Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11713

Description

I recently attempted to install and run QGIS 1.0.1 on a new install of FC10. It was simply installed using yum. Upon running qgis from the terminal I receive a segmentation fault.

A quick backtrace through gdb results in the following:

Program received signal SIGSEGV, Segmentation fault.
0x021c78b4 in ?? () from /usr/lib/libQtGui.so.4
(gdb) backtrace
#0  0x021c78b4 in ?? () from /usr/lib/libQtGui.so.4
#3905  0x06180162 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3906  0x061805ea in ?? () from /lib/libglib-2.0.so.0
#3907  0x06180ac1 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3908  0x01414b07 in link_main_iteration () from /usr/lib/libORBit-2.so.0
#3909  0x013f6d5e in giop_recv_buffer_get () from /usr/lib/libORBit-2.so.0
#3910  0x013fbf46 in ORBit_small_invoke_stub () from /usr/lib/libORBit-2.so.0
#3911  0x013fc179 in ORBit_small_invoke_stub_n () from /usr/lib/libORBit-2.so.0
#3912  0x0140900a in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#3913  0x013cafce in [[ConfigServer]]_ping () from /usr/lib/libgconf-2.so.4
#10 0x013afda7 in gconf_activate_server () from /usr/lib/libgconf-2.so.4
#3914 0x013be309 in ?? () from /usr/lib/libgconf-2.so.4
#3915 0x013bf246 in ?? () from /usr/lib/libgconf-2.so.4
#3916 0x013c0214 in gconf_engine_get_default () from /usr/lib/libgconf-2.so.4
#3917 0x013c7b78 in gconf_client_get_default () from /usr/lib/libgconf-2.so.4
#3918 0x024cbb9e in ?? () from /usr/lib/libQtGui.so.4
#3919 0x024cc1c0 in ?? () from /usr/lib/libQtGui.so.4
#3920 0x024cd5dd in ?? () from /usr/lib/libQtGui.so.4
#3921 0x024b17b5 in QGtkStyle::QGtkStyle () from /usr/lib/libQtGui.so.4
#3922 0x02428c22 in QStyleFactory::create () from /usr/lib/libQtGui.so.4
#3923 0x0212c6e8 in QApplication::style () from /usr/lib/libQtGui.so.4
#3924 0x0212c9dd in QApplicationPrivate::initialize () from /usr/lib/libQtGui.so.4
#3925 0x0212ca7b in QApplicationPrivate::construct () from /usr/lib/libQtGui.so.4
#3926 0x0212d63b in QApplication::QApplication () from /usr/lib/libQtGui.so.4
#3927 0x00161b90 in [[QgsApplication]]::QgsApplication () from /usr/lib/libqgis_core.so.1.0
#3928 0x0809ad78 in main ()

Also, the initial run of gdb produces the following:

Missing separate debuginfos, use: debuginfo-install qgis-1.0.1-1.fc10.i386

An attempt to install the qgis debug reports that it is installed and current.

I have always used Ubuntu in the past and have never encountered any major problems so this is a first.

History

#1 Updated by Paolo Cavallini over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Apparently a duplicate of #1608

#2 Updated by lookingforoil - over 11 years ago

Replying to [comment:1 pcav]:

Apparently a duplicate of #1608

I apologize I did not see the previous ticket. However wouldnt the backtrace be helpful?

Also available in: Atom PDF