Bug report #1608

Segmentation fault Fedora Core 10 rpm qgis-1.0.1-1.fc10.i386 exit code 139

Added by alexlatex - over 11 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Fedora Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11668

Description

Hi,

I'm getting a Segmentation fault before I see anything happen, starting from the command line.
I get exit code 139. In /var/log/messages I get:
segfault at 5c ip 004f60c4 sp bf84c540 error 4 in libQtGui.so.4.4.3[356000+8b4000]

rpm package is qgis-1.0.1-1.fc10.i386

Fedora core 10; I updated stuff, tried again, and got the same results.
I've got plenty of memory and disk space.

Thanks,

Alex

yum_log.txt Magnifier - list of packages updated when QGIS stopped working (4.88 KB) cnieman -, 2009-04-24 05:27 AM

History

#1 Updated by Micha Silver over 11 years ago

Replying to [comment:1 alexlatex]:
Alex:
I don't see any segfault problem with qgis on F10 (64 bit). Can you send more details?

#2 Updated by cnieman - over 11 years ago

I get this in fedora 9 64-bit with qgis 1.0.1. It's fine on my fedora 10 64-bit though.

segfault at b0 ip 00000034c822594c sp 00007fff2cedc8c0 error 4 in libQtGui.so.4.5.0[34c8000000+9aa000]

Also happened with 0.11 (I tried upgrading to 1.0.1 when it first happened). I think it was related to qt-4.5.0-14.fc9.x86_64 getting installed on my system the last time I updated it.

#3 Updated by cnieman - over 11 years ago

It seems it also happens on my 32-bit fedora 9

segfault at 5c ip 021c7824 sp bfe9cea0 error 4 in libQtGui.so.4.5.0[2000000+9ba000]

#4 Updated by Paolo Cavallini over 11 years ago

Please post the libraries version you have (especially qt), so we can see if this is related to a specific version.

#5 Updated by cnieman - over 11 years ago

qt-4.5.0-14.fc9.x86_64 (and i386 on my 32-bit system) was installed on the day that QGIS started segmentation faulting. There were no geo-packages updated (gdal/ogr, etc). I attached a list of everything that was in the update that lead to QGIS failing. Let me know if other library versions would be useful.

#6 Updated by Paolo Cavallini over 11 years ago

See also #1653

#7 Updated by lookingforoil - over 11 years ago

Replying to [comment:7 pcav]:

See also #1653

This ticket contains a gdb backtrace after receiving the same segmentation fault error in FC10.

#8 Updated by starsareblueandfaraway - over 11 years ago

I can confirm that this error appears on both Fedora 10 32-bit and 64-bit and has been like this for at least a week now, ever since the last yum update.

Apr 27 22:33:10 localhost kernel: qgisr4835: segfault at 5c ip 00b798b4 sp bf9ac4d0 error 4 in libQtGui.so.4.5.0[9ca000+9a0000]

Apr 27 17:24:11 localhost kernel: qgisr17740: segfault at b0 ip 000000382442556c sp 00007ffff53d27a0 error 4 in libQtGui.so.4.5.0[3824200000+9a7000]

#9 Updated by Gary Sherman over 11 years ago

I don't think this is a QGIS problem. I suspect this is related to the upgrade to Qt 4.5 on Fedora. Others are using Qt 4.5 with QGIS on other platforms.

#10 Updated by Micha Silver over 11 years ago

And on my F10 laptop (64 bit) qgis seems to be behaving well, with Qt 4.5....

#11 Updated by Paolo Cavallini about 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

It seems solved then. Please reopen it if appropriate.

Also available in: Atom PDF