Bug report #16323

ArcGISMapServer New Connection Not working. Cannot add a layer from service

Added by Dave Sampson over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/ArcGIS
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:24233

Description

As a QGIS user
I want to load a layer from an ArcGISMapServer
So that I can view the feature server layers on my map

Steps: Notes:

Screenshot_20170308_170451.png (216 KB) Giovanni Manghi, 2017-03-08 08:58 AM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback

works as expected here, see attached image

#3 Updated by Dave Sampson over 2 years ago

Thanks for testing.

A detail that i did not think mattered but may is that I am using the ditribution within OSGEO4W. Do you have a version you can test QGIS in? I wonder if something happened during install.

Next, I wonder if there is a debug mode or log file I can monitor to see what is going on.

Thoughts?

#4 Updated by Dave Sampson over 2 years ago

Related to #16321

I just tested this another way in 2.18

  • Ensured QGIS Desktop Closed
  • Open QGIS Browser
  • Added ESRI Mapserver service: Worked
  • opened QGIS desktop: service added to list

So it works through the QGIS browser for me but not through desktop.

Any thoughts on how to narrow down the issue?

#5 Updated by Dave Sampson over 2 years ago

OK,

I think I found the issue. It has been a while since I have used QGIS in all its workflows so it took a while to determine the issue and worked with another user to narrow down the issue.

The issue seems to be in one of the many potential paths to add a layer. So lets go through them:
  • QGIS Browser: ArcGISmapserver > New : WORKS
  • Menu: Layer > Add Layer > Add ArcGis Mapserver Layer: WORKS
  • Manage Layers Toolbar: Add WMS/ESRI vector layer > Add ArcGIS mapserver Layer: WORKS
  • Browser Panel: right click ArcGISMapServer item > New Connection: FAILS

So is seems the issue is with the browser panel.

Can anyone confirm that this workflow also fails for them?

#6 Updated by Giovanni Manghi over 2 years ago

  • Description updated (diff)
The issue seems to be in one of the many potential paths to add a layer. So lets go through them:
  • QGIS Browser: ArcGISmapserver > New : WORKS
  • Menu: Layer > Add Layer > Add ArcGis Mapserver Layer: WORKS
  • Manage Layers Toolbar: Add WMS/ESRI vector layer > Add ArcGIS mapserver Layer: WORKS
  • Browser Panel: right click ArcGISMapServer item > New Connection: FAILS

So is seems the issue is with the browser panel.

Can anyone confirm that this workflow also fails for them?

tested them all on 2.18.7/osgeo4w and Linux, they all work for me.

#7 Updated by Giovanni Manghi over 2 years ago

  • Category changed from 147 to Web Services clients/ArcGIS

#8 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#9 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF