Bug report #16321

ArcGISFeatureServer New Connection Not working. Cannot add a layer from service

Added by Dave Sampson over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Sandro Mani
Category:Web Services clients/ArcGIS
Affected QGIS version:2.18.4 Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24231

Description

As a QGIS user
I want to load a layer from an ArcGISFeatureServer
So that I can view the feature server layers on my map

Steps: Notes:

Screenshot_20170308_171857.png (192 KB) Giovanni Manghi, 2017-03-08 09:13 AM

Screenshot_20170308_171913.png (164 KB) Giovanni Manghi, 2017-03-08 09:13 AM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback

As for the mapservice ticket you just created I can't replicate, kind of.

The connection works fine, the layer list is presented. In this case of the feature service of this specific service there is an error loading the layers. In the past I tested other feature services and worked fine. See attached images.

#3 Updated by Dave Sampson over 2 years ago

Realated to #161321

#4 Updated by Dave Sampson over 2 years ago

OK,

I think I found the issue. It has been a while since I have used QGIS in all its workflows so it took a while to determine the issue and worked with another user to narrow down the issue.

The issue seems to be in one of the many potential paths to add a layer. So lets go through them:
  • QGIS Browser: ArcGISFeatureServer > New : WORKS
  • Menu: Layer > Add Layer > Add ArcGis Featureserver Layer: WORKS
  • Manage Layers Toolbar: Add WMS/ESRI vector layer > Add ArcGIS Feature Layer: WORKS
  • Browser Panel: right click ArcGISFeatureServer item > New Connection: FAILS

So is seems the issue is with the browser panel within QGIS desktop.

Can anyone confirm that this workflow also fails for them?

#5 Updated by Sandro Mani over 2 years ago

  • Assignee set to Sandro Mani

Confirmed, investigating.

#6 Updated by Sandro Mani over 2 years ago

  • Status changed from Feedback to Closed

Fixed in #d6f4621b6622341e68dd966260384c2a4e1e793e

#7 Updated by Giovanni Manghi over 2 years ago

  • Category changed from 148 to Web Services clients/ArcGIS

Also available in: Atom PDF