Bug report #16305

WMS GetLegend Fails in QGIS 2.99

Added by Dave Sampson over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24215

Description

As a QGIS user
I want to access a WMS and have a legend appear in the Layers panel
So that I can match the feature classes to a legend item

Details:
Given this WMS:

http://ec.gc.ca/arcgis/services/data/90be49bd-e492-4251-9082-b756434b8c45/MapServer/WMSServer?request=getcapabilities&version=1.3.0&service=wms&layers=Canadian%20Protected%20Areas%20/%20Aires%20prot%C3%A9g%C3%A9es%20du%20Canada

I should get this legend item:

http://ec.gc.ca/arcgis/services/data/90be49bd-e492-4251-9082-b756434b8c45/MapServer/WmsServer?request=GetLegendGraphic%26version=1.3.0%26format=image/png%26layer=0

QGIS 2.18: works
QGIS 2.99 nightly build (within OSGEO4W Installer) legend fails with "Returned legend images flawed"

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to Severe/Regression
  • Target version changed from Future Release - High Priority to Version 3.0

#2 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#3 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#4 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#5 Updated by Nyall Dawson almost 2 years ago

  • Description updated (diff)
  • Status changed from Open to Feedback

I can't reproduce - I get the exact same legend in 2.18 and 2.99.

Is this still an issue on current nightlies?

#6 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF