Bug report #1612

QGIS crashes when topological editing is enabled

Added by Horst Düster over 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11672

Description

1. enable topological editing
2. Open a shape polygon layer
3. Toggle in editing mode
4. move a junction vertex of more then 2 polygons some times until QGIS crashes
5. gdb gives the following output:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208362784 (LWP 5434)]
0x07a87c91 in QGraphicsSceneFindItemBspTreeVisitor::visit (this=0x9a71b70, items=0x9a9d31c)
    at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsitem.h:321
321     ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsitem.h: File or directory not found
        in ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsitem.h
Current language:  auto; currently c++

History

#1 Updated by Paolo Cavallini about 10 years ago

Works for me (self compiled from trunk, Qt 4.5.1). Could you please test again with a fresh version from svn and let us know? Which Qt are you using?

#2 Updated by Giovanni Manghi about 10 years ago

I also cannot replicate using qgis 1.2 compiled from trunk under ubuntu 9.04.

Please try a recent version and send feedback.

#4 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF