Bug report #15974

Rows of the attribute table seem to be duplicated when saving edits in a shapefile

Added by Jérôme Guélat almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:Vectors
Affected QGIS version:2.18.4 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23890

Description

Here's how to reproduce the bug:

1. Create a new shapefile with a single column named id (as integer)
2. Digitize a few features
3. Open the attribute table and add values in the id column for each feature
4. Stop editing (and save the edits)

The rows will be duplicated in the attribute table. Everything is ok if one closes and reopens the attribute table. This happens with QGIS 2.14.9 and 2.18.1.

out.ogv (2.58 MB) Giovanni Manghi, 2017-04-21 07:29 AM

out.ogv (3.95 MB) Giovanni Manghi, 2017-05-10 10:51 AM


Related issues

Related to QGIS Application - Bug report #15976: Attribute table: rows are switching when adding attributes Closed 2016-12-12

History

#1 Updated by Andrew McAninch over 2 years ago

I can confirm the same behaviour with a .dbf table in 2.18.2.

#2 Updated by Giovanni Manghi over 2 years ago

  • Category set to Vectors
  • Priority changed from Normal to Severe/Regression
  • Target version set to Version 2.14
  • Affected QGIS version changed from 2.18.0 to 2.14.9

#3 Updated by Giovanni Manghi over 2 years ago

  • Target version changed from Version 2.14 to Version 2.18
  • Affected QGIS version changed from 2.14.9 to 2.18.4

2.18.4 also affected.

#4 Updated by Giovanni Manghi over 2 years ago

Adding a screencast.

#5 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#6 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#7 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#8 Updated by Alessandro Pasotti over 2 years ago

  • Description updated (diff)
  • Assignee set to Alessandro Pasotti

#9 Updated by Alessandro Pasotti over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to In Progress
  • Pull Request or Patch supplied changed from No to Yes

Fixed in master with 212acc120c8c2cb901347a77a044e045e30ae7ac
Now working on 2.18 ...

#10 Updated by Alessandro Pasotti over 2 years ago

I cannot reproduce on 2.18.7 (latest release-2_18 branch)

#11 Updated by Giovanni Manghi over 2 years ago

Screencast attached.

#12 Updated by Alessandro Pasotti over 2 years ago

Thanks to Giovanni, we noticed that apparently this bug needs GDAL 2+ to show up on 2.18.x

#13 Updated by Alessandro Pasotti over 2 years ago

  • Status changed from In Progress to Closed

#14 Updated by Ger CO over 2 years ago

Alessandro Pasotti wrote:

Fixed in 2.18 too: 09ef9477db5b68c74ab0c8527533f9b594578399

Thanks a lot for the fix. Highly appreciated.
In Master using the very recent build I still can see the feature count on the top of the attribute table to display a wrong number after edits are saved.
The rows don´t duplicate anymore though. Is this minor issue potentially related to the issue fixed?

#15 Updated by Luigi Pirelli over 2 years ago

Is it a different issue? it has been reported? if no, can you file it?

Ger CO wrote:

In Master using the very recent build I still can see the feature count on the top of the attribute table to display a wrong number after edits are saved.
The rows don´t duplicate anymore though. Is this minor issue potentially related to the issue fixed?

#16 Updated by Luigi Pirelli over 2 years ago

Ger CO wrote:

The rows don´t duplicate anymore though. Is this minor issue potentially related to the issue fixed?

tnx for the test :)

#17 Updated by Jürgen Fischer over 2 years ago

  • Related to Bug report #15976: Attribute table: rows are switching when adding attributes added

Also available in: Atom PDF