Bug report #15900

Magnifier: Zoom factor incompatible with max/min zoom levels

Added by Nathan Perry almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Tools
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:23818

Description

When zooming in and out with the mouse wheel or +/- shortcuts, the Magnifier uses a 2x zoom factor. However, the maximum zoom level is set at 1000%, which is not a multiple of 2x. So, when zooming in the % levels are 100, 200, 400, 800, but then 1000. Thus, when zooming out at a 2x factor, the levels are 1000, 500, 250, 125, 62… Therefore, it is impossible to return to 100% zoom when using the shortcuts or mouse wheel. (A similar situation exists when zooming out from 100 to the minimum of 10%, then back in.)

The max/min zoom levels should be set to a multiple of the 2x factor, or the shortcuts should be set to cycle through pre-defined zoom levels.

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #15861

Also available in: Atom PDF