Feature request #15892

update svg symbol markers

Added by Jochen Schwarze almost 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:23810

Description

In QGIS (2.14.5LTR) when having an svg marker symbol it is not updated when editing it in inkscape and saving it to the same name/location. Even when switching to another svg symbol and then switching back to the one before, the old version of the symbol is displayed and not the one just edited. And simply loading the new version does not work too (the old one is still kept).

Seems to me that there is a QgsSvgCache instantiated when load an svg symbol from file, that is not cleared / updated when load a svg with the same name/location.

Request: Would it be possible to add some sort of 'update' or 'refresh' button to the QgsSvgSelectorWidget that updates the cache when the symbol has changed?

ref. to [[http://gis.stackexchange.com/questions/218978/qgis-update-svg-marker-symbols]]

svg_symbol_marker_refresh_button.png - Proposal: svg marker symbol refresh button (199 KB) Jochen Schwarze, 2016-11-24 05:48 AM

History

#2 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #13565

#3 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF