Bug report #15887

[Advanced Digitizing] hard constraint are overwritten by snapping

Added by R. R. over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Denis Rouzaud
Category:Digitising
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:23805

Description

After enabling 'Distance'(d) or 'Angle' (a) in the 'Advanced Digitizing Panel', snapping to points that are not located at the given distance or angle should be deactivated (see screencast).

158867.mp4 - screencast (1.46 MB) R. R., 2016-11-23 01:13 PM

15887.zip - sample files (8.15 KB) R. R., 2016-11-23 01:16 PM

History

#1 Updated by R. R. over 3 years ago

#2 Updated by R. R. over 3 years ago

See also: #15906 Snapping to vertex while using parallel/perpendicular digitizing causes a vertex to be placed incorretly

#3 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#4 Updated by Denis Rouzaud over 2 years ago

  • Subject changed from Snapping behavior for 'Distance' (d) and 'Angle' (a) to [Advanced Digitizing] hard constraint are overwritten by snapping
  • Priority changed from Normal to High
  • Assignee set to Denis Rouzaud

#5 Updated by Denis Rouzaud over 2 years ago

duplicate of #16998

#6 Updated by Nyall Dawson over 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF