Bug report #16998

Misbehavior of Adv. Digitizing + Snapping tools

Added by Andre Jesus about 3 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.18.11 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24897

Description

When using fixed distance in Advanced Digitizing tool and use a snapping vertice as reference point, it looses the fixed distance value and generate the full length geometry to the snapping point.

Tested on 2.14.17 and 2.18.11

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

what about 2.18.11 and master?

#2 Updated by Andre Jesus about 3 years ago

Giovanni Manghi wrote:

what about 2.18.11 and master?

I tested using 2.14.17 and 2.18.11 on Windows 7 and 10 both 64 bits

#3 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Feedback to Open
  • Affected QGIS version changed from 2.14.17 to 2.18.11

#4 Updated by Denis Rouzaud over 2 years ago

master is not concerned.

#5 Updated by Denis Rouzaud over 2 years ago

duplicate of #15887

#6 Updated by salvatore fiandaca over 1 year ago

  • Priority changed from Normal to High

I confirm the problem in 2.18.28

#7 Updated by Giovanni Manghi over 1 year ago

  • Priority changed from High to Normal

salvatore fiandaca wrote:

I confirm the problem in 2.18.28

it does not matter anymore, qgis 2 is dead, so 3.4/master must be tested instead.

#8 Updated by salvatore fiandaca over 1 year ago

I just tried on QGIS 3.4.4 with new profile, I can not reproduce the problem, everything works fine.
Therefore I close issues

win10 64b OSGeo4W

#9 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

salvatore fiandaca wrote:

I just tried on QGIS 3.4.4 with new profile, I can not reproduce the problem, everything works fine.
Therefore I close issues

win10 64b OSGeo4W

please comment in English, thanks. Before closing let's put the ticket in feedback mode, and await for the issuer response.

#10 Updated by matteo ghetta over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF