Bug report #1582

osgeo4w qgis-grass plugin crashes on Windows Vista

Added by Giovanni Allegri over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11642

Description

Whenever I try to use the qgis-grass plugin (osgeo4w stack) on Windows Vista, I receive a complete crash of QGis. It happens for everything I try to do (load layers, create a locations, etc.), excpet selecting a location and vieweing the list of layers.

The gdb traceback is:

#0 0x774a7dff in ntdll!DbgUiConvertStateChangeStructure ()
from C:\\Windows\\system32\
tdll.dll
#3905 0x77511c93 in ntdll!RtlpNtMakeTemporaryKey ()
from C:\\Windows\\system32\
tdll.dll
#3906 0x774e2b26 in ntdll!RtlTimeToTimeFields ()
from C:\\Windows\\system32\
tdll.dll
#3907 0x77512cf3 in ntdll!RtlpNtMakeTemporaryKey ()
from C:\\Windows\\system32\
tdll.dll
#3908 0x774dbfe8 in ntdll!RtlTimeToTimeFields ()
from C:\\Windows\\system32\
tdll.dll
#3909 0x774c8652 in ntdll!RtlUnhandledExceptionFilter ()
from C:\\Windows\\system32\
tdll.dll
#3910 0x765ec56f in KERNEL32!HeapLock () from C:\\Windows\\system32\\kernel32.dll
#3911 0x76689d6b in msvcrt!free () from C:\\Windows\\system32\\msvcrt.dll
#3912 0x02360000 in ?? ()
#3913 0x00000000 in ?? ()

Very similar to http://trac.osgeo.org/grass/ticket/537
I suspect these are the same memory management problems we're facing on GRASS, with MSVC built libraries...

History

#1 Updated by Giovanni Allegri over 11 years ago

I forgot an important thing: the crash happens whenever db.exe is invoked

#2 Updated by Giovanni Allegri over 11 years ago

Sorry, I meant dbf.exe, obviously :)

#3 Updated by Giovanni Manghi over 11 years ago

wow, it works!?

I just tested the osgeo4w (qgis 1.2) on a fresh install of Vista and seems to me that works finally.

Confirmed?

#4 Updated by Giovanni Manghi over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

I tested it again on a different installation of Vista (at least with version 1.2 from osgweo4w) and seems to works fine. I close this ticket, but please reopen if necessary.

#5 Updated by Giovanni Manghi over 11 years ago

I tested qgis/osgeo4w also windows 7 and seems to work fine: not tested all the GRASS modules, but the ones I tested worked fine.

Also available in: Atom PDF