Feature request #3911

WMS Provider obtained in QgsWMSSourceSelect should be passed to QgsRasterLayer

Added by Brendan Morley - over 14 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Brendan Morley -
Category:Web Services clients/WMS
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:13935

Description

Currently one WMS Provider gets invoked as part of QgsServerSourceSelect and a second is invoked in QgsRasterLayer one a WMS server is selected.

Unfortunately this means the WMS Capabilities gets downloaded twice, which is wasteful and shows up as a small delay (unexplained in the GUI) once the user selected their layers from the WMS server.

This is not a bug, therefore can slip the 0.8 release.

History

#1 Updated by Gavin Macaulay - over 14 years ago

This behaviour contributes to the problem in ticket #8.

#2 Updated by Paolo Cavallini over 11 years ago

Is this still true?

#3 Updated by Paolo Cavallini over 11 years ago

Yes.

#4 Updated by Paolo Cavallini over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

#5 Updated by Paolo Cavallini over 9 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

#6 Updated by Jürgen Fischer over 9 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

fixed in a168fb98 (SVN r15748).

Also available in: Atom PDF