Bug report #15793

Fill ring tool is broken

Added by Luca Mandolesi about 4 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Digitising
Affected QGIS version:3.5(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:23713

Description

Qgis 2.18 32bit osgeo network installer Win 10.

If you have a polygon with a ring, when you use fill ring tool, you obtain a new geometry (as you expect) and a new part of the previous geometry.

Example:

in a shapefile
1 - add a polygon
2 - save it
3 - add a ring
4 - save
5 - fill it with fill ring

Result
- a new geometry added inside the shape of the ring
- a new "multipart" added without a correct shape

Also in spatialite the same, but it doesn't allow to save, and, if you discard the editing, the feature will be saved with a new unformed multipart.
If you try to delete the new multipart, all the geometry will be deleted.

edifici.zip - Shapefile polygonal epsg3004 (1.8 KB) Luca Mandolesi, 2016-10-31 10:29 AM

bug.gif - gif (663 KB) salvatore fiandaca, 2019-01-24 10:09 AM

History

#1 Updated by Luca Mandolesi about 4 years ago

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by salvatore fiandaca almost 2 years ago

  • Affected QGIS version changed from 2.18.0 to 3.5(master)
  • Description updated (diff)
  • Priority changed from Normal to High
  • File bug.gif added
  • Regression? changed from No to Yes
  • Operating System set to Windows 10 64 bit

problem still present in 2.18.28, in 3.4.4 and in the master

it's a regression based on this link:
https://gis.stackexchange.com/questions/89571/how-to-fill-in-a-ring-polygon-in-qgis-2-2

#4 Updated by Giovanni Manghi almost 2 years ago

  • Subject changed from Fill ring unexpected result on polygonal layer - Qgis 2.18 - Win 10 to Fill ring tool is broken
  • Operating System deleted (Windows 10 64 bit)
  • Category changed from Vectors to Digitising

#5 Updated by Nyall Dawson almost 2 years ago

  • Assignee set to Nyall Dawson

#6 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to Feedback

I cannot reproduce. Can you attach a screencast showing the issue?

#7 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

I see where the misunderstanding come from:

the tool in QGIS was made to open/create a ring in a polygon and automatically fill it with a new polygon

BUT

the name "fill ring" makes users think they can fill an existing ring by digitizing a polygon around the ring --> this will cause the result as shown in the attached screencast.

Technically there is no bug BUT I agree that the tool name is at least misleading AND that actually a tool to fill existing rings (possibly with 1 click) should be added to the digitizing toolbar.

#8 Updated by Nyall Dawson almost 2 years ago

The tool already does this -- shift click an existing hole. Maybe it's just a documentation issue, or someone needs to read existing docs? ;)

#9 Updated by Jürgen Fischer almost 2 years ago

Nyall Dawson wrote:

The tool already does this -- shift click an existing hole. Maybe it's just a documentation issue, or someone needs to read existing docs? ;)

see e7744bdcd4708b3d61376ce9aab5ee6a8fe3656a

#10 Updated by Giovanni Manghi almost 2 years ago

Jürgen Fischer wrote:

Nyall Dawson wrote:

The tool already does this -- shift click an existing hole. Maybe it's just a documentation issue, or someone needs to read existing docs? ;)

see e7744bdcd4708b3d61376ce9aab5ee6a8fe3656a

shame on me, I missed the functionality or maybe I just forgot about it.

Also available in: Atom PDF