Bug report #15742

Error in Basic statistics for numeric fields

Added by Paolo Cavallini about 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:2.18.0 Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:23664

Description

running the alg from Processing I get:

Uncaught error while executing algorithm
            Traceback (most recent call last):
              File
"/usr/share/qgis/python/plugins/processing/core/GeoAlgorithm.py", line
203, in execute
                self.processAlgorithm(progress)
              File
"/usr/share/qgis/python/plugins/processing/algs/qgis/BasicStatisticsNumbers.py",
line 175, in processAlgorithm
                data.append(self.tr('Interquartile Range (IQR): {}').format(iqr))
            ValueError: Single '{' encountered in format string

History

#1 Updated by Paolo Cavallini about 4 years ago

  • Affected QGIS version changed from 2.16.3 to 2.18.0

Still true for 2.18

#2 Updated by Alexander Bruy about 4 years ago

Can't reproduce using Processing and QGIS test data. Can you share dataset which causes this?

#3 Updated by Paolo Cavallini about 4 years ago

It happens with any data here, just tested.

#4 Updated by Alexander Bruy about 4 years ago

Strange. Can't reproduce locally, and as I can see Travis also does not report any failure for this alg

#5 Updated by Paolo Cavallini about 4 years ago

  • OS version set to Sid
  • Operating System set to Debian

Very strange indeed. Could it be due to a different version of a lib? I just tested again, and confirm the issue.

#6 Updated by Giovanni Manghi about 4 years ago

  • Status changed from Open to Feedback

Work fine here on 2.18 on both Windows (standalone) and Ubuntu 16.04, with any data.

#7 Updated by Giovanni Manghi about 4 years ago

Paolo Cavallini wrote:

Very strange indeed. Could it be due to a different version of a lib? I just tested again, and confirm the issue.

can you test on another machine (with a different os/os version)? thanks.

#8 Updated by Paolo Cavallini about 4 years ago

Sure, already planned, next days during a course, with several machines.
Thanks for checking.

#9 Updated by Paolo Cavallini about 4 years ago

Verified on 10 Windows boxes, it works on only 2 of them, same error confirmed for the other 8.

#10 Updated by Giovanni Manghi about 4 years ago

Paolo Cavallini wrote:

Verified on 10 Windows boxes, it works on only 2 of them, same error confirmed for the other 8.

where it fails, are all clean installations? have you tried purge the .qgis2 folder and see if anything changes?
On clean installations it does not fail.

#11 Updated by Paolo Cavallini about 4 years ago

This happens in 9 machines, with a variety of settings. Some of them have uninstalled 2.16 before installing 2.18, some starts from a clean .qgis2.
It works in machines with a long history of installations.
I can do further testing after the course.

#12 Updated by Alexander Bruy almost 4 years ago

Still can not reproduce on Windows and Linux, also tests for this alg passed on Travis. Looks like local issue.

#13 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

I can do further testing after the course.

further testing to find the likely local issue are needed. Please reopen if you find a real evidence of a core qgis problem.

#14 Updated by Joao Paulouro about 3 years ago

I can confirm the bug on a QGIS 2.18.13 installation via homebrew on mac. The issue seems to only affect values with decimals (numeric, real, etc) and can only reproduce on Postgis layers. Same layer exported as a shapefile works.

#15 Updated by Giovanni Manghi about 3 years ago

  • Description updated (diff)

Joao Paulouro wrote:

I can confirm the bug on a QGIS 2.18.13 installation via homebrew on mac. The issue seems to only affect values with decimals (numeric, real, etc) and can only reproduce on Postgis layers. Same layer exported as a shapefile works.

chekc if you have a "processing" folder in ~/.qgis2/python/plugins/

if yes delete it, restart qgis and try again.

Also available in: Atom PDF