Bug report #15612

QGis crashes when loading previous versions files

Added by Mauro Dallapina almost 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.16.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:23535

Description

Each time I try to load a .qgs file saved with a previous version of QGis (e.g. 2.14.0) the software crashes.

CassanoMagnago.qgs (137 KB) Mauro Dallapina, 2016-09-26 12:37 AM

P_Ingressi.txt Magnifier (93 Bytes) Mauro Dallapina, 2016-09-26 12:37 AM

P_Scarichi.txt Magnifier (85 Bytes) Mauro Dallapina, 2016-09-26 12:37 AM

P_Sito.txt Magnifier (90 Bytes) Mauro Dallapina, 2016-09-26 12:37 AM

Cassano_Magnago.zip (12.1 KB) Mauro Dallapina, 2016-10-07 12:31 AM

Cassano_Magnago_CTR-1.zip (4.54 MB) Mauro Dallapina, 2016-10-07 12:31 AM

Cassano_Magnago_prov.zip (1.27 MB) Mauro Dallapina, 2016-10-07 12:31 AM

Cassano_Magnago_reg.zip (730 KB) Mauro Dallapina, 2016-10-07 12:31 AM

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Feedback

You'll need to attach a sample project for us to be able to diagnose this.

#2 Updated by Mauro Dallapina almost 4 years ago

I attach a QGS file (version="2.14.0-Essen") and three CSV data files. If needed I can also upload the shapefiles and TIFs.
I suspect the problem may be related to raster loading.

Thanks for the support!

#3 Updated by Even Rouault almost 4 years ago

I couldn't reproduce a crash with the .qgs + 3 .txt you provided. Could you prepare a .zip with everything needed to reproduce the crash ? (possibly the minimum necessary)

#4 Updated by Mauro Dallapina almost 4 years ago

I'm uploading 6 zip files...

#5 Updated by Mauro Dallapina almost 4 years ago

2 of the zip files are too big, so I couldn't upload'em.
I hope the ones uploaded are enough for our purpose.

In case, you could copy file A5D3.tif and rename it as A5D4.tif (not uploaded), since they are of the same dimensions.

#6 Updated by Giovanni Manghi almost 4 years ago

  • Category set to Project Loading/Saving

#7 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Tested with QGIS 2.18.2 on both Linux and Windows and cannot replicate.

Likely to be a local issue, anyway please reopen in case you find that this is defintely not caused by a 3rd party plugin (remove all them) and/or a old setting/configuration (try delete the .qgis2 folder and restart qgis).

Also available in: Atom PDF