Bug report #15322

QGIS 2.16 breaks when starting the Globe plugin

Added by Samuel Fernando Mesa Giraldo over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Pirmin Kalberer
Category:C++ plugins/Globe
Affected QGIS version:2.16.0 Regression?:No
Operating System:Arch Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:23254

Description

I get the next error when start Globe plugin in QGIS v2.16 in Arch Linux.

Warning: QCss::Parser - Failed to load file  "/style.qss" 
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Not found the file directory
Warning: QFileSystemWatcher: failed to add paths: /home/samtux/.qgis2//project_templates
Warning: QLayout: Attempting to add QLayout "" to QgsPanelWidgetStack "mWidgetStack", which already has a layout
zsh: segmentation fault (core dumped)

The version of OSGearth is 2.7 with the following compilation instructions:

https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=osgearth-qt4


Related issues

Related to QGIS Application - Bug report #15323: QGIS 2.16 breaks when starting the Globe plugin Closed 2016-07-21

History

#1 Updated by Samuel Fernando Mesa Giraldo over 3 years ago

Here are I captured a video with the error report plugin Globe:

https://vimeo.com/175843495

#2 Updated by Anita Graser over 3 years ago

FYI: No crashes on Windows.

#3 Updated by Samuel Fernando Mesa Giraldo over 3 years ago

I made a new installation of Arch Linux and compiling OSGearth and QGIS again and now everything works correctly. Apparently the problem is due to old files and settings of QGIS, OSGearth or OpenSceneGraph.

Please close issue.

#4 Updated by Nyall Dawson over 3 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Also available in: Atom PDF