Bug report #15290

composer: label item's margin values inverted when enabling html

Added by Mathieu Pellerin - nIRV over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Mathieu Pellerin - nIRV
Category:Map Composer/Printing
Affected QGIS version:2.16.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23224

Description

Margins for html-enabled label items are inverted due to a small issue in the stylesheet creation process whereas mMarginX and mMarginY are served in the wrong order.

This affects the newly-released 2.16.0 as well as master.

Associated revisions

Revision 7352df69
Added by Mathieu Pellerin - nIRV over 3 years ago

[composer] fix html label stylesheet's margin (fixes #15290)

Revision 9f330fc9
Added by Nyall Dawson over 3 years ago

Merge pull request #3309 from nirvn/html_label_fix

[composer] fix html label stylesheet's margin (fixes #15290)

Revision 5dabc9de
Added by Nyall Dawson over 3 years ago

[composer] fix html label stylesheet's margin (fixes #15290)

(cherry-picked from 7352df6935368ca74fd2eef2bfe4b364908b9286)

Revision 9953875a
Added by Nyall Dawson over 3 years ago

[composer] fix html label stylesheet's margin (fixes #15290)

(cherry-picked from 7352df6935368ca74fd2eef2bfe4b364908b9286)

History

#1 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF