Bug report #3309

Plugin Installer can't guess the plugin version

Added by Aren Cambre almost 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:Borys Jurgiel
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:13369

Description

Per #3307 (Plugin Installer declines to update plugin), the Plugin Installer will indicate Plugin reinstalled correctly even when the plugin was in fact not installed correctly.

Since Plugin reinstalled correctly appeared erroneously, the UI is misinforming the user.

History

#1 Updated by Borys Jurgiel almost 11 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Actually the plugin is reinstalled correctly, it just wrongly reports to QGIS its version number. Installer is prepared to cope with dozens errors occuring in plugins, but not for each one of course. We're just working on a new plugin system, yet more "authorproof" and carrying on metadata consistency :)

Also available in: Atom PDF