Bug report #15268

Qgis 2.16: Save world file does not work.

Added by Steven Veen over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:2.16.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23204

Description

When I export a map to a jpeg or tiff using the composer and I've checked 'Save world file' the world file does not appear. (The jpg or tiff does.)

worldfile.png (7.52 KB) Steven Veen, 2016-07-13 12:12 AM

Associated revisions

Revision 38a811b3
Added by Nyall Dawson about 3 years ago

[composer] Fix save world file does not work (fix #15268)

Revision c9449c8b
Added by Nyall Dawson about 3 years ago

[composer] Fix save world file does not work (fix #15268)

(cherry-picked from 38a811b377cf7d0d50e2c76346eadfdd8ef87956)

Revision 9f6f08a4
Added by Nyall Dawson about 3 years ago

[composer] Fix save world file does not work (fix #15268)

(cherry-picked from 38a811b377cf7d0d50e2c76346eadfdd8ef87956)

History

#1 Updated by Klas Karlsson over 3 years ago

It works for me (on other OS), but I noted that the "Reference Map" selector under "Export Settings" was blank when I first activated the "Save world file" option.

Can you verify that this selector has the correct map selected as reference and that it still doesn't work.

#2 Updated by Steven Veen over 3 years ago

When I open the same project in Qgis 2.14.4 everything goes fine.

#3 Updated by Donovan Cameron about 3 years ago

I've noticed the World File isn't generated on either Windows 8.1 (via OSGeo4W installer) or Arch Linux.

The Reference Map is selected, wasn't blank but set to Map 0.

#4 Updated by salvatore fiandaca about 3 years ago

Win 10 64-bit and OSGeo4w works well, you must select the 'reference map'!!!

#5 Updated by Novarese   about 3 years ago

Under Win7_64 it works as well, but you have to flag "Print as raster" too.
The option "Save world file" seems useless, because the exported TIFF is a full Geotiff.

#6 Updated by Jukka Rahkonen about 3 years ago

There are programs which can't read the GeoTIFF tags so Save world file option is not useless.

#7 Updated by John Tull about 3 years ago

The same is true on OS X with 2.16.2, i.e., no world file is being generated on export with the setting correctly applied in the composer export options.

#8 Updated by Nyall Dawson about 3 years ago

  • Assignee set to Nyall Dawson
  • Priority changed from Normal to Severe/Regression

#9 Updated by Nyall Dawson about 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF