Bug report #15244

photos not resizing in feature form when edit widget width and height set to 512x512

Added by Donovan Cameron over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Edit widget
Affected QGIS version:2.14.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23180

Description

I've specified column as "photo" with a height and width of 512 in the edit widget that contains full paths to photos.

In the attribute table, when switching to form view, the first image is resized properly, but as soon as you click on the next feature in the list it becomes cropped instead.
Going back to the first feature, it also looses its resizing and becomes cropped like the other photos.

The identify tool works fine and shows the photo resized properly.

I've attached pictures to show how the identify tool opens the feature form with the photo resized correctly and another that shows the attribute table with the photo cropped instead of resized.

Testing it on Windows 8.1.

qgis_2.14.3_-_identify_tool_to_feature_form_with_photo_widget.png - identify tool showing picture resized correctly (574 KB) Donovan Cameron, 2016-07-08 12:53 PM

qgis_2.14.3_-_attribute_table_feature_form_with_photo_widget.png - attribute table showing picture cropped instead of resized (738 KB) Donovan Cameron, 2016-07-08 12:53 PM

History

#1 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Please test on 2.16 or 2.14.4. there's been related changes which may have fixed this.

#2 Updated by Donovan Cameron over 4 years ago

  • Status changed from Feedback to Closed

Thanks! Looks like setting the width and height to 512x512 or other values works as expected.

Closing as fixed.

Also available in: Atom PDF