Bug report #15157

Lack of standard features in Vector menu.

Added by Michal Jurewicz about 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:23096

Description

I have two version of QGIS installed on my Mac - 2.14.3 and master 2.15 323abe3. For some time there is no standard (basic) vector edition and analyze option in Vector menu, like geometry tools and etc. Please, check the screenshot.
How can I fix this? I believe it's some missing plugin or dependencies but I don't know which one.

Zrzut_ekranu_2016-06-28_o_17.06.33.png - master (485 KB) Michal Jurewicz, 2016-06-28 08:24 AM

Zrzut_ekranu_2016-06-28_o_17.23.26.png - 2.14.3 (521 KB) Michal Jurewicz, 2016-06-28 08:24 AM

History

#1 Updated by Alexander Bruy about 4 years ago

  • Status changed from Open to Feedback

Please check that you have no Processing plugin in your ~/.qgis2/python/plugins.

#2 Updated by Michal Jurewicz about 4 years ago

I had and I deleted processing/ in this location and nothing changed. Still there aren't these functions in master.

#3 Updated by Calvin Hamilton about 4 years ago

See ticket #15118. They are both talking about the same problem. I had to delete the HKEY_CURRENT_USER->Software->QGIS registry to clean it up. Something is getting clobbered.

#4 Updated by Michal Jurewicz about 4 years ago

I have installed QuickMapService, so it can be the same problem. How to repair this on OS X? There is no Registry Keys :)

#5 Updated by Calvin Hamilton about 4 years ago

Someone else will have to answer that since I don't work with OS X.

#6 Updated by Michal Jurewicz about 4 years ago

It has to be something different. I deleted both QGIS version with all additional files like ~/.qgis2 and qgis plist in ~/Library/Preferences, then I reinstall fresh copy of master and still the same problem.

#7 Updated by Giovanni Manghi about 4 years ago

  • Category set to GUI

#8 Updated by Jonathan Virga almost 4 years ago

Hello,

I'm using QGis dev (2.15.0-Master, a0f329e) on Ubuntu and have the same problem : no vector tools in the Vector menu.
When using QGis 2.14.2 compiled from source, everything is fine.

#9 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

In general there are no issues with multiple installations (in particular under Windows) but under Linux and OsX can be more tricky and source of problems. Moreover "Master" the development version of QGIS can always come with some issue.

#10 Updated by Jonathan Virga over 3 years ago

My issue came from an old processing directory in .qgis2/python/plugins.
Fixed by deleting it.

Also available in: Atom PDF