Bug report #15118

[Processing] Options dialog remove vector menu entries

Added by Arnaud Morvan about 4 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23059

Description

When processing options dialog is accepted, processing vector menu entries disapear but are not recreated.
This should be due to the deleteLater effect.

Also note that, in processing.gui.menus.removeAlgorithmEntry the menu entry is search by his setting path, which should have changed.

Also note that the options dialog tree item says "restart required", but the dialog try to update the vector menu.


Related issues

Related to QGIS Application - Bug report #15730: "Geometry tools" vector menu entry is duplicated Closed 2016-10-20
Related to QGIS Application - Bug report #16633: Vector menu is duplicated Closed 2017-05-28

History

#1 Updated by Calvin Hamilton about 4 years ago

I am not 100% sure this is caused by the processing plugin. I first encountered it after I installed QuickMapServices. I have had it happen twice. Something is getting clobbered in the registry. If you delete HKEY_CURRENT_USER->Software->QGIS then it clears up the problem. I haven't gone deeper to try and figure out which registry key is causing the problem.

#3 Updated by Giovanni Manghi about 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#4 Updated by Jürgen Fischer about 3 years ago

#5 Updated by Nyall Dawson about 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • Description updated (diff)

Not an issue in 3.2

Also available in: Atom PDF