Bug report #16633

Vector menu is duplicated

Added by Romain Blanc over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Translations and international
Affected QGIS version:2.18.9 Regression?:Yes
Operating System:W10x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24533

Description

In QGIS 2.18.8 and 2.18.9, the vector menu is shown twice (one after the Plugin menu and one after the Help menu). The second contains the following tools: search, geoprocessing, geometry, analysis, data management.
It seems this bug is linked with the french language because the second Vector (Vecteur) is not translated in english when I change the language of QGIS.

See screenshots and video attached.

qgis_fr.PNG - Menu bar in french language (3.95 KB) Romain Blanc, 2017-05-28 11:23 AM

qgis_en.PNG - Menu bar in english language (3.87 KB) Romain Blanc, 2017-05-28 11:23 AM

vecteur1.PNG - Vector menu (between Plugin and Raster) (7.3 KB) Romain Blanc, 2017-05-28 11:23 AM

vecteur2.PNG - Vector menu (after Help) (3.51 KB) Romain Blanc, 2017-05-28 11:23 AM

vector_twice.mp4 - The two vectors menus (946 KB) Romain Blanc, 2017-05-28 11:23 AM

montage.jpg (141 KB) Romain Blanc, 2017-05-28 11:28 AM

plugins.PNG (5.65 KB) Romain Blanc, 2017-05-28 04:32 PM


Related issues

Related to QGIS Application - Bug report #15118: [Processing] Options dialog remove vector menu entries Closed 2016-06-23
Related to QGIS Application - Bug report #14535: fix duplicate entries in the vector menu caused by ftools... Closed 2016-03-20

History

#1 Updated by Romain Blanc over 3 years ago

#2 Updated by Giovanni Manghi over 3 years ago

  • Category changed from GUI to Translations and international

#3 Updated by Jürgen Fischer over 3 years ago

  • Status changed from Open to Feedback

Do you have a local processing plugin (in you private .qgis2/python/plugins)?

#4 Updated by Romain Blanc over 3 years ago

No "processing" folder in my user directory .qgis2/python/plugins.

#5 Updated by Jürgen Fischer over 3 years ago

  • Related to Bug report #15118: [Processing] Options dialog remove vector menu entries added

#6 Updated by Jürgen Fischer over 3 years ago

  • Related to Bug report #14535: fix duplicate entries in the vector menu caused by ftools on version upgrade added

#7 Updated by Andre Joost over 3 years ago

I experienced the same some time ago with the German locale: #15330

After the translation was fixed, I still had to remove .qgis2 from the registry (see #15118) and the user folder.

#8 Updated by Jürgen Fischer over 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Andre Joost wrote:

After the translation was fixed, I still had to remove .qgis2 from the registry (see #15118) and the user folder.

The pull request mentioned in that ticket was merged. Use the "Reset to defaults" in the processing configuration dialog.

Also available in: Atom PDF