Bug report #15103

Identify features: forms should stay in foreground

Added by Andreas Neumann over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Matthias Kuhn
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23045

Description

When opening feature forms with the "Identify features" tool, there often multiple open forms that stay in the background of the main QGIS windows and can remain there unnoticed.

It is suggested to research if a window mode exists that forces these form windows to stay infront of the main QGIS application window - so they don't go unnoticed by the user.

Associated revisions

Revision 0783e8fc
Added by Matthias Kuhn over 3 years ago

Keep attribute dialog in front

Fix #15103

Revision 66c47d7a
Added by Matthias Kuhn over 3 years ago

Keep feature form only on top of application and not system

Better fix #15103

History

#1 Updated by Harrissou Santanna over 3 years ago

I'd not be in favor of keeping them foreground. Could be noisy.
A first step can be to have only one form per feature (see #13520)

#2 Updated by Andreas Neumann over 3 years ago

hm - what exactly do you mean by "noisy"? Isn't it up to the user to close the window he doesn't need anymore? It's as easy as pressing the "x" button.

BTW: foreground doesn't mean modal. It would still be possible to interact with the main window.

I agree though, that multiple forms for the same feature is bad. But multiple forms from different features is important for comparison reasons.

If we want to please all users - we could have an option on the application level to enable/disable this behavior ;-)

An additional idea would be to enable/disable the form "in front" behavior per feature form. KDE has such a "per Window" setting which forces the Window to stay on top of all the other Windows. In older versions KDE also had a button in the Window title bar for this to quickly enable/disable this behavior.

#3 Updated by Harrissou Santanna over 3 years ago

hm - what exactly do you mean by "noisy"? Isn't it up to the user to close the window he doesn't need anymore? It's as easy as pressing the "x" button.

It's one-click more! :)
No problem with having it optional though

#4 Updated by Matthias Kuhn over 3 years ago

Please try the current behavior.

On Linux it has been like that for years and I found it always confusing on the two other operating systems.

#5 Updated by Anonymous over 3 years ago

  • Status changed from Open to Closed

#6 Updated by Matthias Kuhn over 3 years ago

Actually not exactly, it is now also on top of other applications which is not really what I wanted... I'll check again.

#7 Updated by Andreas Neumann over 3 years ago

@Harrissou: why one-click more? It is exactly the same nr of clicks as before - it just would be on top of the main window. Or did you never close any of the background "Identify Results Windows" and let them accummulate somewhere unnoticed?

#8 Updated by Harrissou Santanna over 3 years ago

@Andreas, sorry for the delay.
I don't really care about these forms. I can close them as I can not. It doesn't matter they're open (and hidden) given that I do not compare features through this way and if I need to see again values of a feature, I just need to click on it and open a new form.
This is theoretical because actually, I work with Mac and Windows and:
  • on Mac, I have my mouse configured to see in one-click all the dialogs related to the current application, so I can easily switch and close unneeded dialogs
  • and same thing, on Windows, hovering over QGIS icon in launch (?) bar shows all dialogs opened, so just switch

What sounds embarrassing with having the form stay foreground is that you are obliged to close it in order to see all the map canvas while before you just needed to click the main interface.
Note that i'haven't tested Mathias fix yet.

Also available in: Atom PDF