Bug report #13520

multiple Feature Attributes forms can be opened for the same feature when Identified

Added by Steven Mizuno about 5 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Tools
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21564

Description

Multiple Feature Attributes forms can be opened for the same feature when "Auto open form" is checked and you click multiple times on one feature or if you do View feature form multiple times on an item in Identify Results. This can be confusing when many such forms are opened, and it can lead to loss of data when editing a layer.

Examples: which form for a given feature was changed? or make changes in different forms of a given feature -- which one wins?.

As the form windows are top-level windows they may be obscured by the QGIS main window which can be even more confusing. There is a clue that forms are still open as the highlight is drawn one for each form. And the windows are shown in the task bar as well.

I believe the Features Attributes form should be application modal, or at the very least, create only one window per feature and then put focus on that window on subsequent clicking on a feature.

This is somewhat related to #13465


Related issues

Related to QGIS Application - Feature request #13465: Identify Results panel : clicking on "Clear results" shou... Open 2015-09-30

Associated revisions

Revision 7b8fb793
Added by Jürgen Fischer over 3 years ago

avoid opening multiple attribute forms for a single feature in identify
(fixes #13520)

On behalf of Faunalia, sponsored by ENEL

Revision 20197c2f
Added by Jürgen Fischer over 3 years ago

avoid opening multiple attribute forms for a single feature in identify
(fixes #13520)

On behalf of Faunalia, sponsored by ENEL

(cherry picked from commit 7b8fb793cf63483477b8af1670541aca033e8ab9)

Revision 6dfcf402
Added by Jürgen Fischer over 3 years ago

fix 20197c2fa (refs #13520)

Revision 392b638e
Added by Jürgen Fischer over 3 years ago

fix 20197c2fa (refs #13520)

(cherry picked from commit 6dfcf402278ea271cbbe960758937c9b98616db9)

History

#1 Updated by Anita Graser about 5 years ago

-1 for modal because it's unnecessarily restrictive

+1 for only one window per feature

#2 Updated by Harrissou Santanna about 5 years ago

Anita Graser wrote:

-1 for modal because it's unnecessarily restrictive

+1 for only one window per feature

Totally agree (no modal and only one form)!

#3 Updated by Giovanni Manghi about 5 years ago

  • Target version deleted (Version 2.12)

#4 Updated by Giovanni Manghi over 4 years ago

  • Priority changed from High to Normal

#5 Updated by Jürgen Fischer over 3 years ago

  • Status changed from Open to Closed

#6 Updated by Jürgen Fischer over 3 years ago

  • Related to Feature request #13465: Identify Results panel : clicking on "Clear results" should close all feature attribute's form added

Also available in: Atom PDF