Bug report #15098

ArcGIS Map/Feature server dialogs do not open on Windows

Added by Giovanni Manghi over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Web Services clients/ArcGIS
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23040

Description

Message:

"Cannot get Arcgis map server select dialog from provider".

is OK on Linux.

Tagging as severe as is a new feature not working as expected.


Related issues

Related to QGIS Application - Bug report #16631: Cannot get select dialog (ArcGIS) Closed 2017-05-27

History

#1 Updated by Sandro Mani over 3 years ago

I am unable to reproduce this with my windows build. Did you compile yourself or what build are you using?

#2 Updated by Giovanni Manghi over 3 years ago

Sandro Mani wrote:

I am unable to reproduce this with my windows build. Did you compile yourself or what build are you using?

osgeo4w, using the latest "dev" package available there.

#3 Updated by Sandro Mani over 3 years ago

  • Assignee changed from Sandro Mani to Jürgen Fischer

The qjson dependency is missing. Once you install the library, it works.
@Jürgen: can you add the dependency to the package?

#4 Updated by Jürgen Fischer over 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

#5 Updated by Edward H over 3 years ago

It seems to me that the qjson dependency is not automatically added if I use the latest "dev" package. I do manually install the library... (osgeo4w - 64 bits - Windows 7 64 bits)

#6 Updated by Giovanni Manghi over 2 years ago

  • Category changed from 147 to Web Services clients/ArcGIS

#7 Updated by Jürgen Fischer over 2 years ago

  • Description updated (diff)
  • Priority changed from Severe/Regression to Low
  • Regression? set to No
  • Easy fix? set to No

qgis-dev doesn't need qjson anymore.

#8 Updated by Jürgen Fischer over 2 years ago

Also available in: Atom PDF