Bug report #14836

Processing: checkbox list in wrong order in Modeler

Added by Jorge Santos over 4 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:2.8.6 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:22790

Description

When running a model in the processing framework that produces a stack of bands as input (Band1, Band2, Band3...) The sequence are listed randomly in the Merge executing window (see pic).
I've tried models created under QGIS windows versions 2.6 / 2.8 / 2.10 and 2.12 without success. Version 2.0 works fine.

MergeInput_Wrong_order.png (65.9 KB) Jorge Santos, 2016-05-18 07:24 PM

Processing_Merge_wrong_Order.mp4 (4.03 MB) Jorge Santos, 2016-05-18 07:24 PM

QGIS20_Merge_Multiple_Selection.png (180 KB) Jorge Santos, 2016-05-24 10:26 AM

QGIS20_Processing_Merge_Right_Order.mp4 (1.44 MB) Jorge Santos, 2016-05-24 10:26 AM

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Assignee changed from Giovanni Manghi to Victor Olaya

#2 Updated by Alexander Bruy over 4 years ago

It never worked in a such way in modeler. It is not possible to determine layers order in modeler.

#3 Updated by Jorge Santos over 4 years ago

I'm not sure. Please see the attached files. The box shows in right order (QGIS 2.0 Dufour).

#4 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#5 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to end of life
  • Status changed from Open to Closed

Also available in: Atom PDF