Bug report #14810

Uncheck 'include Z dimension' in 'save vector layer as' doesn't work

Added by Nicolas Boisteault almost 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22766

Description

  • load a 2.5D vector layer
  • right click on it -> Save as
  • select geometry type
  • uncheck 'include z dimension'
  • Click OK

The resulting layer still has z dimension.

You can test with attached file.

carre2154.geojson (811 Bytes) Nicolas Boisteault, 2016-05-13 02:51 AM

History

#1 Updated by Alexander Bruy almost 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in master and 2.14.3. Please reopen if necessary

#2 Updated by Nicolas Boisteault almost 4 years ago

This issue still occurs in 2.14.3 64 bits on windows 7 64 bits.
Did you mean it is fixed in master and so it will fixed in 2.14.4?

#3 Updated by Alexander Bruy almost 4 years ago

I think yes. I can't reproduce it with lastest master and 2.14.3 (89a1f5b).

If possible, please test with nightly builds.

#4 Updated by Jürgen Fischer over 2 years ago

  • Category set to Unknown

Also available in: Atom PDF