Bug report #14748

Selecting features by radius fails

Added by R. R. over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Nyall Dawson
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22705

Description

Selecting features by radius fails in master. I've set the priority to blocker, as it is a regression.

select_features_by_radius.mp4 (478 KB) R. R., 2016-05-01 02:51 AM

14748.tar.gz (1.23 MB) R. R., 2016-05-03 12:39 PM

14748_2.tar.gz (1.95 MB) R. R., 2016-05-04 11:39 AM

qgis_2-17-0_14748.mp4 (1.12 MB) R. R., 2016-07-17 04:32 AM

Associated revisions

Revision 33a5ee7a
Added by Nyall Dawson over 3 years ago

Fix selecting features by radius (fix #14748)

Revision 68739c6a
Added by Nyall Dawson over 3 years ago

Fix selecting features by radius (fix #14748)

(cherry-picked from 33a5ee7ab47c8c6db2985ef755ef6bdca23b36a0)

History

#1 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Feedback

Cannot reproduce - can you please provide more details or a reproducible test case?

#2 Updated by R. R. over 3 years ago

I've tested different data providers (Memory, Shape, SpatiaLite), geometry types (polygon, linestring, point) and CRS (WGS84 4326, MGI / Austria GK East 31256). Selecting features by radius fails every time. OS is Ubuntu 16.04 LTS.

#3 Updated by Nyall Dawson over 3 years ago

Can you share a self contained project + data file which demonstrates this issue? I'm totally unable to reproduce.

#4 Updated by R. R. over 3 years ago

Hi Nyall, I've attached a sample .qgis file including .shp geometries.

#5 Updated by Matthias Kuhn over 3 years ago

I get a lot of errors in the GEOS message pannel

Exception: IllegalArgumentException: Points of LinearRing do not form a closed linestring

Running v.clean from processing and trying on the cleaned dataset, the tool works again.

#6 Updated by R. R. over 3 years ago

The GEOS message panel throws the same exception for point features (see attachment).

#7 Updated by Giovanni Manghi over 3 years ago

  • Target version set to Version 2.16
  • Status changed from Feedback to Open
  • Category set to Map Canvas

#8 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Closed

#9 Updated by R. R. over 3 years ago

Here in QGIS 2.17.0 master selecting features by radius is still not working.

#10 Updated by Nyall Dawson over 3 years ago

  • Status changed from Reopened to Feedback

I can't reproduce, following the same steps in the video. What am I missing?

#11 Updated by R. R. over 3 years ago

Perhaps something is wrong with my installation? I can't reproduce this issue on my Ubuntu laptop running QGIS 2.16 Nødebo.

#12 Updated by Sandro Santilli about 3 years ago

  • Resolution set to fixed/implemented
  • Assignee set to Nyall Dawson
  • Status changed from Feedback to Closed

Reinhard I guess you had an installation problem, since you cannot reproduce on your laptop.
Feel free to reopen if you can still reproduce with 2.17 (and include exact commit if you can reproduce). Thanks

Also available in: Atom PDF