Bug report #14704

Encoding problems with Processing toolbox

Added by vedar sum over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/QGIS
Affected QGIS version:2.18.4 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:22665

Description

new description

Some qgis algs create outputs where the attribute tables have encoding issues. Examples are buffer and dissolve. Maybe others are also affected (an example that works as expected in "voronoi polygons").

Sample data attached.

old description
Hi,

I'm using QGIS 2.14.1 on Windows 10 through OSGeo4W setup.

I noticed that if I process a vector layer (i.e. UTF-8 encoded geojson) with QGIS algorithm (i.e. crop, Voronoi, etc) through Processing toolbox, result layer has attribute table with question marks instead expected characters. While if I run the same algorithm through QGIS menu, result layer is correctly encoded.

I noticed also that this affects GDAL/OGR algorithms, besides QGIS algorithms, while not SAGA algorithms.

For reference I open a question first here: http://gis.stackexchange.com/questions/190137/qgis-algoritms-have-encoding-problems

portugal_continental_3763_1.zip (82 KB) Giovanni Manghi, 2017-02-28 01:16 PM

History

#1 Updated by Anita Graser over 3 years ago

  • Category set to Processing/QGIS

#2 Updated by Anita Graser over 3 years ago

  • Priority changed from Normal to High

#3 Updated by Alexander Bruy over 3 years ago

Canyou share sample dataset?

#4 Updated by Alexander Bruy over 3 years ago

  • Status changed from Open to Feedback

#5 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

closing for lack of feedback, please reopen if necessary.

#6 Updated by Saber Razmjooei almost 3 years ago

  • Resolution deleted (not reproducable)
  • Status changed from Closed to Reopened
  • Priority changed from High to Severe/Regression

In my case, the problem was with path.

The bug is present in 2.18 and 2.14.

#7 Updated by Giovanni Manghi over 2 years ago

  • Operating System deleted (Windows)
  • Affected QGIS version changed from 2.14.1 to 2.18.4
  • OS version deleted (10)
  • File portugal_continental_3763_1.zip added

Saber Razmjooei wrote:

In my case, the problem was with path.

The bug is present in 2.18 and 2.14.

Tested on 2.18.4 on Windows special chars in paths seems to be not an issue for QGIS algs. They are an issue for GDAL/OGR ones (will file a different ticket).

Encoding problems in outputs do not seem to be a problem with GDAL/OGR algs or with all QGIS algs, but certainly a few QGIS algs are affected, like dissolve and buffer (and maybe others).

#8 Updated by Giovanni Manghi over 2 years ago

  • Target version changed from Version 2.14 to Version 2.18

#9 Updated by Giovanni Manghi over 2 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

#10 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#11 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#12 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#13 Updated by Alexander Bruy over 2 years ago

  • Status changed from Reopened to Feedback
  • Description updated (diff)

Can't reproduce with latest 2.18 using attached sample data and native buffer and dissolve algorithms.

#14 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Alexander Bruy wrote:

Can't reproduce with latest 2.18 using attached sample data and native buffer and dissolve algorithms.

confirmed, if some other tool is affected please reopen this one.

Also available in: Atom PDF