Bug report #14654

Qgis 2.14 - Processing, Additional Providers is broken. Missing msys directory.

Added by Dan G over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.14.3 Regression?:No
Operating System:MS Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22618

Description

Hello

I have installed Qgis 2.14 using "QGIS Standalone Installer Version 2.14 (64 bit)" onto fresh, clean Windows 7 64-bit installations.

After Qgis has been installed 'Additional Providers' in the Processing Toolbox is broken, I get an error message that the path "C:/PROGRA~1/QGISES~1/apps\\msys" does not exist.
As a result of this it is not possible to activate additional geoalgorithms, such as 'Tools for LiDAR data' for example.

I have tested with both qgis 2.14.0 and 2.14.1.
During the installation of qgis I have tested with both the default installation path (C:\\Program Files\\Qgis Essen) and a simpler path like "C:\\qgis_essen" but the error persists regardless.

I will attach some screenshots.

VirtualBox_Win7VM_2_10_04_2016_11_30_54.png - Error message (152 KB) Dan G, 2016-04-10 02:47 AM

VirtualBox_Win7VM_2_10_04_2016_11_43_20.png - Qgis directory structure and contents (137 KB) Dan G, 2016-04-10 02:47 AM


Related issues

Duplicates QGIS Application - Bug report #14431: Cannot set Msys folder path in QGIS 2.14 Closed 2016-03-06

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

duplicate of #14431

#2 Updated by Dan G over 4 years ago

  • Status changed from Closed to Reopened

This issue still persists with latest Qgis 2.14.2.

After Qgis has been installed 'Additional Providers' in the Processing Toolbox is broken, I get an error message that the path "C:/PROGRA~1/QGISES~1/apps\\msys" does not exist.

#3 Updated by Alexander Bruy over 4 years ago

  • Status changed from Reopened to Feedback
  • Category changed from Windows Package to Processing/Core

Please test with completely clean system (no old registry entries, empty ~/.qgis2)

#4 Updated by Dan G over 4 years ago

This issue still persists with latest Qgis 2.14.3.
Yes, testing is performed on fresh, clean Windows 7 64-bit installations.

After Qgis has been installed, opening 'Processing options' gives an error message that the path "C:/PROGRA~1/QGISES~1/apps\\msys" does not exist. (Error message is received when pressing the 'OK'-button for example.)

#5 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Open
  • Assignee set to Victor Olaya
  • Resolution deleted (duplicate)
  • Affected QGIS version changed from 2.14.1 to 2.14.3

Still true with the 2.14.3 standalone installer on a completely clean environment. Not sure it has been fixed in master of the dev branch of 2.14.

#6 Updated by Alexander Bruy over 4 years ago

  • Status changed from Open to Feedback

Should be fixed in latest point release

#7 Updated by Alexander Bruy over 4 years ago

  • Status changed from Feedback to Closed

Please reopen in necessary

Also available in: Atom PDF