Bug report #14634

Composer: the legend should show only enabled layers

Added by Patrick Valsecchi over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22598

Description

In the composer, I didn't find a way to not have the legend of the disabled layers. The disabled layers are not show in the map, but they are shown in the legend.

Even when I tick the option to show only the ones present in the map, the disabled layer's legend is present.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback
  • Category set to Map Composer/Printing

arguably a feature request(?).

#2 Updated by Harrissou Santanna over 4 years ago

Not really. I think this is a wrong behaviour and a blocker issue for many releases now (since layer tree has landed if i'm not wrong). see #7177 and #13575

#3 Updated by Giovanni Manghi about 4 years ago

is this any different from #13575 ?

#4 Updated by Patrick Valsecchi about 4 years ago

  • Status changed from Feedback to Closed

Yes, it is. Closing...

Also available in: Atom PDF