Bug report #14517

QGIS 2.14 Processing filter very slow/freeze

Added by Magnus Nilsson over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22490

Description

Hi
Using the filter function in processing is very slow, it freezes QGIS for a while for each character you enter.

QGIS 2.14, 64 bit
Windows 7, 64 bit

http://osgeo-org.1560.x6.nabble.com/QGIS-2-14-Processing-filter-VERY-slow-freeze-td5256090.html


Related issues

Related to QGIS Application - Bug report #14583: Data directory pollution with 0 or 1 files without extension Closed 2016-03-29

History

#1 Updated by Andreas Neumann over 3 years ago

What exactly means "filter function in processing" - is this a specific algorithm? From which provider?

Can you be a bit more specific what you are trying to do - in what part of processing?

#2 Updated by Magnus Nilsson over 3 years ago

The problem occurs when I use the search field for finding an algorithm.

#3 Updated by Andreas Neumann over 3 years ago

Ok - so in the toolbox "search" field?

I just tested it in 2.14 and 2.15 nightly.

I am - like you - also on Win 7, 64bit, with QGIS 64bit.

So I wonder what is the difference between your and my installation.

Can you share what processing providers are enabled? Menu "Processing" --> "Options" -- "Providers".

Can you try de-activating all the providers that you most likely don't need and see if this helps?

Just trying to find out what triggers this slowness.

#4 Updated by Andreas Neumann over 3 years ago

Also - if you don't know what a provider does or offer - better disable it. You most likely won't need it if you don't know what it does.

As an example - I never use the Orfeo Toolbox, Taudem or Lastools - because I either don't work in the domain of Photogrammetry/Hydrologic modelling or don't own a Lastools license.

#5 Updated by Magnus Nilsson over 3 years ago

Yes, the "search" field. I disabled all of the providers and searching is still very slow.

Is there anything else I can check to help find the cause?

#6 Updated by Giovanni Manghi over 3 years ago

  • OS version deleted (64 bit)
  • Priority changed from Normal to Severe/Regression
  • Operating System deleted (Windows 7)

I confirm this issue, also on Linux and also on master.

I have the impression that this happens on projects with several layers, but I have not had time yet to double check it.

#7 Updated by Magnus Nilsson over 3 years ago

At least in my case, it seems to occur in all projects, even fresh ones with zero layers.

#8 Updated by Maximilian Krambach over 3 years ago

I have this issue in processing 2.12.99, which is shipped with my install on qgis (debian testing), but not in processing 2.12.2 (in qgis plugin repository).

Also, I get a (GDAL) message every time I type a letter:

ERROR 4: `1' not recognised as a supported file format.

#9 Updated by Andreas Neumann over 3 years ago

very strange - I also have 2.12.99 and the search filter for algorithms in the processing toolbox is working fine.

Did you check if there is just one processing instance and no overlap of an installation in the user profile and one in the QGIS installation directory?

How about other plugins? Do you have many of them enabled? What if you disable all other plugins?

From time to time there are plugins who really mess up QGIS and interfere with other plugins ...

#10 Updated by Maximilian Krambach over 3 years ago

It happens on a "fresh install" (deleted ~.qgis2/ and ~.config/QGIS), and also if every toolbox item is disabled.

#11 Updated by Andreas Neumann over 3 years ago

adding this information from Claus Sørensen

On a QGIS workshop march 9. in Silkeborg, Denmark with 30+ enthusiastic newcomers to QGIS, we encountered 3 pc's with extremely slow – tending to non-functional – search box in "Processing -> Toolbox".

OS'es ranging from Win7, Win8.1 and Win10. Win7 and Win10 unknown version but with 2.14.0 also unknown bit flavour.

My Win8.1 Pro in 64-bit with QGIS version 2.14.0 in 64 bit and no administrative rights.

By elevating security on the installation folder – in my case c:\\Program Files\\QGIS Essen\\ - to allow users "change" rights, the search box became functional again – on every pc.

#12 Updated by Magnus Nilsson over 3 years ago

I do not have admin rights on my computer, so this might be the issue.

#13 Updated by Victor Olaya over 3 years ago

I cannot reproduce the error, but i think it might be related to the fact that the filter now tries to find the search string also in the help (the short one) of the algorithm

Those of you experiencing this that can do a small change in the code, could you try removing these 2 lines from the Processing code and see if this fixes the issue?

https://github.com/qgis/QGIS/blob/master/python/plugins/processing/gui/ProcessingToolbox.py#L136-L137

Thanks in advance!

#14 Updated by Maximilian Krambach over 3 years ago

Yes, commenting the two lines resolves the issue. Also, I don't have write permissions in the .99 version of the plugin, so this may be a cause.

#15 Updated by Victor Olaya over 3 years ago

Thanks! So it seems that the issue is in fetching that help or scanning it, which in certain systems is a bottleneck, apparently

I will disable those lines and leave the original behaviour, searching only in alg names, not in alg help. That will temporarily fix the problem

I will leave this issue open for a while, so if anyone can provide more info, please add it here

Thanks!

#16 Updated by Maximilian Krambach over 3 years ago

Another thing I found is that the faulty search writes an empty file named "1" into my ~.qgis2/python/ folder. This may cause a major freeze in some windows systems due to file lock and/or permissions?

#17 Updated by Maximilian Krambach over 3 years ago

Geoalgorithm.py :90 getCopy(self) creates an instance of an algorithm with parameters.

GdalAlgorithm.py executes getCopy() to get the name of the module. It also sets parameter to "1", which later appears as output.

So somewhere one or several algorithms are executed with a parameter of "1" when initialized. From my output it seems to be some GDAL or OGR algorithm.

#18 Updated by Alexander Bruy over 3 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Fixed in master. Please reopen if necessary

#19 Updated by Jürgen Fischer over 3 years ago

Alexander Bruy wrote:

Fixed in master. Please reopen if necessary

Which commit? Was it backported?

#20 Updated by Alexander Bruy over 3 years ago

1fdd177c81
I just backported it.

Also available in: Atom PDF