Bug report #14583

Data directory pollution with 0 or 1 files without extension

Added by Alain FERRATON over 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22554

Description

QGIS created 0 and 1 files without extension in QGIS / bin (what purpose?).

If we start QGIS from a QGS file or other extension associated with QGIS. These files are created in the launch directory ( data directories are polluted)


Related issues

Related to QGIS Application - Bug report #14517: QGIS 2.14 Processing filter very slow/freeze Closed 2016-03-17

History

#1 Updated by Maximilian Krambach over 4 years ago

related to #14517 . The Geoprocessing Toolbox tries to run algorithms with the settings "1" or "0" each time the search of the toolbox is used, resulting in a null byte output.

#2 Updated by Alain FERRATON over 4 years ago

May be, but it's not necessarily linked .
not the same directory as # 14517

#3 Updated by Maximilian Krambach over 4 years ago

The issue in #14517 leaves the "1" file in whatever directory QGIS is started from, whenever the toolbox is used (In the other bug thread I just started qgis from a strange location, but I checked for the offending files and they're in every directory recently used with qgis)
Could you delete the file while QGIS is running, use the toolbox (just typing a letter in the search) and check if it reappears? If so, it's probably the same bug, which seems to be fixed for the next version.

#4 Updated by Alain FERRATON over 4 years ago

You are right.
the file will appear when you type a letter in the search, but also leaving qgis without using the Toolbox.

#5 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

The issue seems have been fixed in master, please reopen if necessary.

#6 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF