Bug report #14481

If already opened QGIS Browser (standalone and panel) doesn't show newly connected usb drives

Added by Harrissou Santanna over 4 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22458

Description

hi,
I connect an usb drive disk and it's not listed among the drives of QGIS browser panel. However, it's available when using QGIS Browser Standalone.

tested on windows 10.

======================================

New description:
Testing further. Actually, the drive isn't found if the browser panel was opened before the drive is connected. Hitting 'Reload' does nothing, neither do closing and reopening the browser panel.
However, opening the second browser panel shows the drive.
But if both panels were opened before the connection, none will find it.
It looks like the list of drives is initialised only at the first opening of the panel. If not done automatically, at least reloading button should also trigger reinitialisation of the drive list, imho.

Same behaviour for QGIS Browser application: doesn't update the list of drives.

Hope that helps a dev to fix this issue.

browserMissDrive.PNG - Right panel is a QGIS opened after the usb drive is connected (37.1 KB) Harrissou Santanna, 2018-02-28 11:16 AM

Associated revisions

Revision 035c78be
Added by Nyall Dawson almost 2 years ago

Add native platform interface for usb storage events

Allows native interfaces to send a signal when a USB storage device
is inserted/removed

Refs #14481

Revision af4a1df9
Added by Nyall Dawson almost 2 years ago

[browser] Correctly show drives inserted (or removed!) after QGIS launch

Fixes #14481, #9843

History

#1 Updated by Harrissou Santanna over 4 years ago

  • Target version set to Version 2.14
  • Subject changed from usb connected drives are not available in QGIS Browser panel to If already opened QGIS Browser (standalone and panel) doesn't show newly connected usb drives

#2 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#3 Updated by Harrissou Santanna over 2 years ago

Now, none of the browsers finds the drive if it has been connected after you open QGIS (see screenshot in which the drive G is missing in the instance that was opened before i connect it - Reload does nothing)

#4 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to In Progress

#5 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF