Bug report #14441

Labeling settings not properly restored after save style / load style

Added by Daan Goedkoop almost 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22420

Description

When going into layer properties and choosing "load style", the label settings in the dialog UI are not updated and if you close the dialog with "OK", no labels appear.

However, if one chooses "load style" and then closes the dialog with "Cancel", the layer style is set correctly. (The loaded styling with labels appears after a refresh of the map canvas.)


Related issues

Related to QGIS Application - Bug report #13667: rule based labelling is not saved in qml style files Closed 2015-10-25

History

#1 Updated by Daan Goedkoop almost 4 years ago

I cannot compile / debug right now, but I guess that this might be related to issue #13667. Maybe the QgsLabelingWidget::adaptToLayer introduced to fix that bug doesn't trigger QgsLabelingWidget::labelModeChanged, or not at the right moment.

#2 Updated by Wouter Yperman over 3 years ago

I can confirm this issue and the work around.
QGIS 2.14 on a Mac

#3 Updated by R. R. over 3 years ago

See bug report #14224

#4 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #14224

Also available in: Atom PDF